File: .travis.yml

package info (click to toggle)
modsecurity 3.0.3-1+deb10u1
  • links: PTS, VCS
  • area: main
  • in suites: buster
  • size: 41,992 kB
  • sloc: cpp: 25,929; ansic: 15,785; sh: 5,357; python: 3,556; yacc: 2,896; makefile: 1,394; lex: 1,344; perl: 464; ruby: 69; php: 42
file content (59 lines) | stat: -rw-r--r-- 1,262 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
dist: trusty
sudo: true

addons:
  apt:
    packages:
    - libfuzzy-dev
    - libyajl-dev
    - libgeoip-dev
    - liblua5.2-dev
    - liblmdb-dev
    - cppcheck

language: cpp

compiler:
  - clang
  - gcc

os:
  - linux
  - osx

env:
  - OPTS="--enable-parser-generation $OPTS"
  - OPTS="--without-curl $OPTS"
  - OPTS="--without-yajl $OPTS"
  - OPTS="--without-geoip $OPTS"
  - OPTS="--without-lmdb $OPTS"
  - OPTS="--without-ssdeep $OPTS"
  - OPTS="--without-lua $OPTS"
  - OPTS="--without-maxmind $OPTS"

before_script:
  - echo $TRAVIS_OS_NAME
  - '[ "$TRAVIS_OS_NAME" != osx ] || brew update'
  - '[ "$TRAVIS_OS_NAME" != osx ] || brew install cppcheck'
  - '[ "$TRAVIS_OS_NAME" != osx ] || brew install libmaxminddb'
  - '[ "$TRAVIS_OS_NAME" != linux ] || sudo add-apt-repository --yes ppa:maxmind/ppa'
  - '[ "$TRAVIS_OS_NAME" != linux ] || sudo apt-get update'
  - '[ "$TRAVIS_OS_NAME" != linux ] || sudo apt-cache search maxmind'
  - '[ "$TRAVIS_OS_NAME" != linux ] || sudo apt-get install -y libmaxminddb-dev'

script:
  - ./build.sh
  - ./configure $OPTS
  - make parser
  - make
#
# Temporarily disabled.
# - make -j$(getconf _NPROCESSORS_ONLN)
# Leading build to crash with parser enabled.
# Not sure why.
#
  - make check
  - make check-static