File: molly-guard.postrm

package info (click to toggle)
molly-guard 0.6.4
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 88 kB
  • ctags: 11
  • sloc: xml: 286; sh: 203; makefile: 41
file content (49 lines) | stat: -rwxr-xr-x 1,422 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#!/bin/sh
# see: dh_installdeb(1)

set -e

# summary of how this script can be called:
#        * <postrm> `remove'
#        * <postrm> `purge'
#        * <old-postrm> `upgrade' <new-version>
#        * <new-postrm> `failed-upgrade' <old-version>
#        * <new-postrm> `abort-install'
#        * <new-postrm> `abort-install' <old-version>
#        * <new-postrm> `abort-upgrade' <old-version>
#        * <disappearer's-postrm> `disappear' <overwriter>
#          <overwriter-version>
# for details, see http://www.debian.org/doc/debian-policy/ or
# the debian-policy package


case "$1" in
    remove)
        for cmd in halt poweroff reboot shutdown coldreboot ; do
            dpkg-divert --package molly-guard --rename --remove /sbin/$cmd
        done

        # Disable diversions of pm-utils binaries until #812545 is fixed
        #for cmd in pm-hibernate pm-suspend pm-suspend-hybrid ; do
        #    dpkg-divert --package molly-guard --rename --remove /usr/sbin/$cmd
        #done

        (test -d /lib/molly-guard && rmdir --ignore-fail-on-non-empty /lib/molly-guard) || true
    ;;

    purge|upgrade|failed-upgrade|abort-upgrade|abort-install|disappear)
        # Nothing to do
    ;;

    *)
        echo "postrm called with unknown argument \`$1'" >&2
        exit 1
    ;;
esac

# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.

#DEBHELPER#

exit 0