1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51
|
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk
include /usr/share/dpkg/pkg-info.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND := -lpthread
ifneq (,$(findstring nodoc,$(DEB_BUILD_OPTIONS)))
DOCS=OFF
else
DOCS=ON
endif
%:
dh $@
override_dh_auto_configure:
[ "$(DOCS)" = "ON" ] || echo "Found 'nodoc' in 'DEB_BUILD_OPTIONS'; not building documentation"
dh_auto_configure -- \
-DBUILD_VERSION=$(DEB_VERSION_UPSTREAM) \
-DENABLE_MONGOC=ON \
-DENABLE_BSON=ON \
-DENABLE_MAN_PAGES=$(DOCS) \
-DENABLE_HTML_DOCS=$(DOCS) \
-DENABLE_MAINTAINER_FLAGS=ON \
-DENABLE_TESTS=OFF \
-DENABLE_ZLIB=SYSTEM
override_dh_auto_install:
dh_auto_install
find $(CURDIR)/debian/tmp/usr/include -type f -name "*.h" -print0 | \
xargs -0r sed -i -e 's@\([" ]\)[^ ]*-f\(file\|debug\)-prefix-map=[^ ]*\([" ]\)@\1\3@g'
override_dh_makeshlibs:
dh_makeshlibs -V
|