1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
|
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk
include /usr/share/dpkg/pkg-info.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND := -lpthread
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -B$(CURDIR)/build -- \
-DBUILD_VERSION=$(DEB_VERSION_UPSTREAM) \
-DENABLE_TESTS=OFF \
-DENABLE_UNINSTALL=OFF
override_dh_auto_build:
dh_auto_build -B$(CURDIR)/build -- all doxygen-current
override_dh_auto_install:
dh_auto_install -B$(CURDIR)/build
find $(CURDIR)/debian/tmp -type d -empty -delete
rm -f $(CURDIR)/debian/tmp/usr/share/mongo-cxx-driver/LICENSE
override_dh_auto_test:
override_dh_missing:
dh_missing --fail-missing
|