File: changelog

package info (click to toggle)
monopd 0.10.2-4
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 1,008 kB
  • sloc: cpp: 6,263; sh: 837; makefile: 35
file content (275 lines) | stat: -rw-r--r-- 9,176 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
monopd (0.10.2-4) unstable; urgency=medium

  * Switch to debhelper-compat = 13.
  * Declare compliance with Debian Policy 4.5.1.

 -- Markus Koschany <apo@debian.org>  Sun, 03 Jan 2021 00:01:02 +0100

monopd (0.10.2-3) unstable; urgency=medium

  * Switch to compat level 11.
  * Declare compliance with Debian Policy 4.2.1.
  * Use canonical VCS URI.
  * Remove get-orig-source target.
  * Use https for Format field.

 -- Markus Koschany <apo@debian.org>  Fri, 07 Dec 2018 21:35:24 +0100

monopd (0.10.2-2) unstable; urgency=medium

  * Declare compliance with Debian Policy 3.9.8.
  * Vcs-Git: Use https.
  * Update my email address.
  * monopd: Depend on lsb-base (>= 3.0-6).

 -- Markus Koschany <apo@debian.org>  Wed, 21 Dec 2016 20:26:22 +0100

monopd (0.10.2-1) unstable; urgency=medium

  * Imported Upstream version 0.10.2.

 -- Markus Koschany <apo@gambaru.de>  Sun, 06 Sep 2015 20:58:24 +0200

monopd (0.10.1-1) unstable; urgency=medium

  * Imported Upstream version 0.10.1.

 -- Markus Koschany <apo@gambaru.de>  Sun, 19 Jul 2015 16:06:47 +0200

monopd (0.10.0-1) unstable; urgency=medium

  * Imported Upstream version 0.10.0.
  * d/rules: Add get-orig-source target.
  * New build-dependencies:
    - Replace libmath++-dev with libmuparser-dev.
    - Add libutfcpp-dev to Build-Depends.
  * Do not install README.monopigator. It is gone.
  * monopd.docs: Install new file README.metaserver.
  * Update debian/copyright for new release.

 -- Markus Koschany <apo@gambaru.de>  Sat, 18 Jul 2015 12:35:01 +0200

monopd (0.9.8-2) unstable; urgency=medium

  * Upload to unstable.

 -- Markus Koschany <apo@gambaru.de>  Tue, 28 Apr 2015 09:39:45 +0200

monopd (0.9.8-1) experimental; urgency=medium

  * Imported Upstream version 0.9.8.
    - Fixes CVE-2015-0841: off-by-one error in network code.
      Thanks to Niko Tyni for the report and Sylvain Rochet for the patch.
      (Closes: #781043)
  * Add upstream's pgp key to verify new releases.
  * Add pgpsigurlmangle option to debian/watch.
  * Drop all patches. They were merged upstream.
  * Update copyright years.

 -- Markus Koschany <apo@gambaru.de>  Tue, 24 Mar 2015 13:16:58 +0100

monopd (0.9.7-3) experimental; urgency=medium

  * Team upload.
  * B-D on libsystemd-daemon-dev instead of libsystem-dev and
    add the 01-libsystemd-daemon patch.  Closes: #779763
  * Bump Standards-Version to 3.9.6 with no changes.
  * Add the 02-typos patch to fix a couple of typographical and
    grammatical errors.
  * Drop the unnecessary version of the dh-systemd B-D.
  * Point to cgit in the Vcs-Browser source control field.

 -- Peter Pentchev <roam@ringlet.net>  Thu, 05 Mar 2015 17:36:20 +0200

monopd (0.9.7-2) unstable; urgency=medium

  * monopd.socket: Move description to section [Unit]
    Thanks to Laurent Bonnaud for the report. (Closes: #750671)

 -- Markus Koschany <apo@gambaru.de>  Wed, 18 Jun 2014 12:14:42 +0200

monopd (0.9.7-1) unstable; urgency=medium

  * Imported Upstream version 0.9.7

 -- Markus Koschany <apo@gambaru.de>  Tue, 27 May 2014 23:06:21 +0200

monopd (0.9.6-1) unstable; urgency=medium

  * Imported Upstream version 0.9.6.

 -- Markus Koschany <apo@gambaru.de>  Mon, 24 Mar 2014 20:10:52 +0100

monopd (0.9.5-2) unstable; urgency=medium

  * Add Documentation, User and Group sections to monopd.service.

 -- Markus Koschany <apo@gambaru.de>  Tue, 04 Mar 2014 14:38:43 +0100

monopd (0.9.5-1) unstable; urgency=medium

  * Imported Upstream version 0.9.5.
    - Add support for IPv6 and systemd.
  * Update watch file and point to the new upstream location
    at tuxfamily.org.
  * Drop all patches. Merged upstream.
  * debian/control:
    - Drop libcapsinetwork-dev from Build-Depends.
      Essential features of libcapsinetwork were merged into monopd and
      IPv6 support was added.
    - Add pkg-config to Build-Depends.
    - Add libsystemd-daemon-dev [linux-any] to Build-Depends.
    - Update homepage field and point to gtkatlantic.gradator.net.
  * Add monopd.service and monopd.socket file and support systemd.
  * Update monopd.6 man page.
  * Use dh-systemd helper.
  * Update debian/copyright. Add new BSD license.

 -- Markus Koschany <apo@gambaru.de>  Fri, 28 Feb 2014 15:39:47 +0100

monopd (0.9.3-7) unstable; urgency=medium

  * New maintainer Debian Games Team. (Closes: #634499)
  * Add myself to Uploaders.
  * Bump compat level to 9 and require debhelper >= 9.
  * debian/rules:
    - Drop cdbs and switch to dh-sequencer.
    - Build with --parallel and --with autoreconf.
    - Install data files to /usr/share/games/monopd
    - Enable all hardening build flags. Add CPPFLAGS.patch.
  * monopd.init:
    - Improve init script and source /lib/lsb/init-functions.
    - Implement the status option.
  * Bump Standards-Version to 3.9.5, no changes.
  * debian/control:
    - Add VCS-fields.
    - Remove versioned dependencies. They are trivially satisfied now.
  * Install upstream changelog only once.
  * Add monopd.6 man page.
  * debian/patches: Rename filename extensions from diff to patch.

 -- Markus Koschany <apo@gambaru.de>  Tue, 17 Dec 2013 17:55:05 +0100

monopd (0.9.3-6) unstable; urgency=low

  * QA upload.

  [ James Westby ]
  * Use --chuid instead of /bin/su to run the daemon as 'nobody'. Using
    su mean that a pam session was opened, hence a consolekit session,
    hence trying to shut down via consolekit would require the root password
    as it thought there were multiple users logged in. (LP: #443441)

  [ Bilal Akhtar & Ryan Kavanagh ]
  * Dropped atlantik and atlantikdesigner from suggests because they are not
    available in Intrepid.

  [ Paul Wise ]
  * Dropped atlantik and atlantikdesigner from the package description because
    they are not available any more.
  * The software is dead upstream, drop the generalisation efforts from the
    package description.
  * Use the sourceforge project as the upstream project location since
    the other sites are spam sites.
  * Clean up the patches and add DEP-3 headers to them
  * Use the new FSF address in copyright information

 -- Paul Wise <pabs@debian.org>  Tue, 18 Oct 2011 17:11:49 +0800

monopd (0.9.3-5) unstable; urgency=low

  * Orphaning package (see #634499).
  * Bump Standards-Version to 3.9.2.
  * Update to 3.0 (quilt) source format.

 -- Daniel Schepler <schepler@debian.org>  Mon, 18 Jul 2011 22:07:44 -0700

monopd (0.9.3-4) unstable; urgency=low

  * Add extra includes needed for compilation with current g++-4.3.
  * Add LSB dependency information to the init script, thanks Lintian.
  * Update Standards-Version to 3.7.3 (no changes needed).

 -- Daniel Schepler <schepler@debian.org>  Fri, 11 Jan 2008 17:04:28 -0500

monopd (0.9.3-3) unstable; urgency=low

  * Add missing #include's to fix compilation with gcc-4.3. (Closes: #417322)
  * Update watch file: listing the download directory is now forbidden, so
    we have to go through the download page.

 -- Daniel Schepler <schepler@debian.org>  Tue, 05 Jun 2007 12:20:32 -0400

monopd (0.9.3-2) unstable; urgency=low

  * New patch monopd-0.9.3-dosfix.diff for CVE-2006-1046:
    Fixes a remote DOS vulnerability which could cause the daemon to eat up
    CPU time on the server. (Closes: #355797)
  * Bump Standards-Version to 3.7.2 (no changes needed).

 -- Daniel Schepler <schepler@debian.org>  Sat, 12 Aug 2006 17:05:23 -0400

monopd (0.9.3-1) unstable; urgency=low

  * g++-4.0 transition.
  * New upstream release.
  * Update debian/watch file to new location.
  * Update to Standards-Version 3.6.2 (no changes needed).

 -- Daniel Schepler <schepler@debian.org>  Fri,  8 Jul 2005 16:45:20 -0700

monopd (0.9.0-1) unstable; urgency=low

  * New upstream release.
  * Version libcapsinetwork-dev build dependency to 0.2.5 or later.

 -- Daniel Schepler <schepler@debian.org>  Fri, 13 Feb 2004 18:05:30 -0800

monopd (0.8.3-1) unstable; urgency=low

  * New upstream release.
    + Fixes a DOS vulnerability. (Closes: #229580)

 -- Daniel Schepler <schepler@debian.org>  Tue, 27 Jan 2004 17:25:00 -0800

monopd (0.8.2-1) unstable; urgency=low

  * New upstream release
  * Update to Standards-Version 3.6.1 (no changes needed).
  * Add a debian/watch file.

 -- Daniel Schepler <schepler@debian.org>  Tue, 21 Oct 2003 01:54:00 -0700

monopd (0.8.1-2) unstable; urgency=low

  * Fix debian/rules for new cdbs.

 -- Daniel Schepler <schepler@debian.org>  Tue,  8 Jul 2003 05:32:23 -0700

monopd (0.8.1-1) unstable; urgency=low

  * New upstream release.
  * Remove hack to use prefix instead of DESTDIR in install, which is
    no longer necessary.

 -- Daniel Schepler <schepler@debian.org>  Mon,  7 Jul 2003 13:56:33 -0700

monopd (0.8.0-1) unstable; urgency=low

  * New upstream release.
  * Switch to using cdbs.
  * Update to Standards-Version 3.5.10 (no changes needed).

 -- Daniel Schepler <schepler@debian.org>  Sat, 21 Jun 2003 16:27:21 -0700

monopd (0.7.0-2) unstable; urgency=medium

  * Start monopd as nobody user.

 -- Daniel Schepler <schepler@debian.org>  Tue,  4 Mar 2003 06:04:58 -0800

monopd (0.7.0-1) unstable; urgency=low

  * Initial Release. (Closes: #180321)

 -- Daniel Schepler <schepler@debian.org>  Sun, 23 Feb 2003 02:14:21 -0800