1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
|
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh $@
override_dh_auto_build:
VPATH=.. $(MAKE) -C build
override_dh_auto_install:
dh_auto_install
cp build/auth-plug.so debian/mosquitto-auth-plugin/usr/lib/mosquitto-auth-plugin/auth-plugin.so
cp build/np debian/mosquitto-auth-plugin/usr/bin/
override_dh_auto_configure:
mkdir -p build
cp -l Makefile config.mk build
override_dh_auto_clean:
rm -rf build
|