1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43
|
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
VENDOR ?= $(shell dpkg-vendor --query vendor)
SRCDIR = $(CURDIR)/js/src
ifeq ($(VENDOR), Debian)
ifneq (,$(findstring $(DEB_BUILD_ARCH),armel))
CONFIGURE_FLAGS += --disable-methodjit
endif
endif
ifeq ($(VENDOR), Ubuntu)
ifneq (,$(findstring $(DEB_BUILD_ARCH),armel armhf))
CONFIGURE_FLAGS += --enable-thumb2
endif
endif
%:
dh $@ --sourcedirectory=$(SRCDIR) --with pkgkde-symbolshelper,autotools_dev
override_dh_auto_configure:
cd $(SRCDIR) && ./configure \
--host=$(DEB_HOST_GNU_TYPE) \
--build=$(DEB_BUILD_GNU_TYPE) \
--prefix=/usr \
--with-system-nspr \
--disable-tests \
--disable-strip \
--enable-ctypes \
--enable-threadsafe \
--enable-system-ffi \
$(CONFIGURE_FLAGS)
override_dh_auto_test:
make -C $(SRCDIR) -k check || true
|