1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74
|
export CFLAGS = $(shell dpkg-buildflags --get CFLAGS) -Wall -Wunused -Wno-error=format-security -fcommon
MPG321_ARCH = $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
INSTALL_PROGRAM = /usr/bin/install
configure: configure-stamp
configure-stamp:
dh_testdir
ifeq ($(MPG321_ARCH),linux)
./configure --prefix=/usr --mandir=/usr/share/man --disable-mpg123-symlink --enable-alsa=yes
else
./configure --prefix=/usr --mandir=/usr/share/man --disable-mpg123-symlink --enable-alsa=no
endif
touch configure-stamp
build: build-arch build-indep
build-arch: configure-stamp
build-indep: configure-stamp
clean:
dh_testdir
dh_testroot
rm -f configure-stamp
[ ! -f Makefile ] || $(MAKE) distclean
dh_clean
install: build
dh_testdir
dh_prep
dh_installdirs
$(MAKE) install DESTDIR=$(CURDIR)/debian/mpg321 mandir=/usr/share/man INSTALL_PROGRAM="$(INSTALL_PROGRAM)"
binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
dh_installdocs
dh_installman
dh_installchangelogs
dh_link
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure
|