1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46
|
-include /usr/share/dpkg/buildtools.mk
export PKG_CONFIG ?= pkg-config
export DEB_BUILD_MAINT_OPTIONS=hardening=+all,-pie
export DEB_CFLAGS_MAINT_APPEND=-flto
export DEB_CPPFLAGS_MAINT_APPEND = -D_FILE_OFFSET_BITS=64
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
DEB_CFLAGS_MAINT_APPEND=-fno-aggressive-loop-optimizations -fno-strict-overflow
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
MAKEOPTIONS = V=1 UNAME='$(DEB_HOST_ARCH_OS)' HOST_CPU='$(DEB_HOST_GNU_CPU)' APIDIR=/usr/include/mupen64plus/ DEBUG=1 DEBUGGER=1 PREFIX=/usr/ LIBDIR="/usr/lib/$(DEB_HOST_MULTIARCH)" PIC=1 OPTFLAGS="-DNDEBUG" SHAREDIR="/usr/share/games/mupen64plus/" SDL_CONFIG=sdl2-config OPENCV=1 NETPLAY=1
ifeq ($(DEB_HOST_ARCH),armhf)
MAKEOPTIONS += USE_GLES=1 NEON=1
endif
binary binary-arch binary-indep build build-arch build-indep clean install install-arch install-indep:
dh $@ --sourcedirectory="projects/unix"
override_dh_auto_test:
override_dh_auto_clean:
dh_auto_clean -- $(MAKEOPTIONS)
override_dh_auto_build:
dh_auto_build -- all $(MAKEOPTIONS)
override_dh_auto_install:
dh_auto_install -- $(MAKEOPTIONS)
override_dh_installchangelogs:
dh_installchangelogs RELEASE
.PHONY: binary binary-arch binary-indep build build-arch build-indep clean install install-arch install-indep \
override_dh_auto_clean override_dh_auto_test override_dh_auto_build override_dh_auto_install override_dh_installchangelogs
|