1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
|
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
CFLAGS += $(CPPFLAGS)
export AUTOHEADER=true
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- \
--prefix=/usr \
--sysconfdir=/etc \
--libdir=/usr/lib/nagios \
--libexecdir=/usr/lib/nagios/plugins \
--localstatedir=/var \
--enable-ssl \
--with-logdir=/var/log \
--with-ssl-lib=/usr/lib/$(DEB_HOST_MULTIARCH) \
--with-piddir=/run/nagios
override_dh_auto_build:
dh_auto_build -- all
override_dh_auto_install:
|