1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
|
Description: skip test that tries to connect to server on non-loopback address
nanoc tests check to make sure nanoc is not listening on non-loopback
addresses by trying to connect to the port and expecting connection refused.
However, local configuration can cause a different failure to be returned,
such as a timeout due to a DROP rule in a firewall. Skip this test, which
is exceedingly unlikely to ever regress in the distro.
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=893447
Author: Steve Langasek <steve.langasek@ubuntu.com>
Last-Updated: 2018-11-06
@@ -68,17 +68,5 @@
end
end
- it 'does not listen on non-local interfaces' do
- addresses = Socket.getifaddrs.map(&:addr).select(&:ipv4?).map(&:ip_address)
- non_local_addresses = addresses - ['127.0.0.1']
-
- if non_local_addresses.empty?
- skip 'Need non-local network interfaces for this spec'
- end
-
- run_nanoc_cmd(['view', '--port', '50385']) do
- expect { Net::HTTP.get(non_local_addresses[0], '/', 50_385) }.to raise_error(Errno::ECONNREFUSED)
- end
- end
end
end
|