1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137
|
PKGNAME = $(shell head -1 debian/changelog | sed 's/ .*//')
VERSION = $(shell head -1 debian/changelog | sed 's/.*(//;s/).*//')
PKGFILES = $(PKGNAME)_$(VERSION)_$(shell dpkg --print-architecture).deb
CHANGES = $(PKGNAME)_$(VERSION)_$(shell dpkg --print-architecture).changes
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
config.status: configure
dh_testdir
ifneq "$(wildcard /usr/share/misc/config.sub)" ""
cp -f /usr/share/misc/config.sub config.sub
endif
ifneq "$(wildcard /usr/share/misc/config.guess)" ""
cp -f /usr/share/misc/config.guess config.guess
endif
./configure \
--host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
--prefix=/usr --mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" \
LDFLAGS="-Wl,-z,defs"
build: build-stamp
build-stamp: config.status
dh_testdir
$(MAKE)
touch $@
clean:
dh_testdir
dh_testroot
rm -f build-stamp
[ ! -f Makefile ] || $(MAKE) distclean
rm -f config.sub config.guess
dh_clean
install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
$(MAKE) DESTDIR=$(CURDIR)/debian/nap install
rm -rf $(CURDIR)/debian/nap/usr/doc
binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs ChangeLog
dh_installdocs
dh_installexamples
dh_installmenu
dh_installdebconf
dh_installman doc/nap.1
ln -fs nap.1 $(CURDIR)/debian/nap/usr/share/man/man1/napping.1
dh_link
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install
package:
dh_testdir
dpkg-buildpackage -rfakeroot
dist:
dh_testdir
dpkg-buildpackage -rfakeroot
deb:
dh_testdir
dpkg-buildpackage -rfakeroot -us -uc
debclean:
dh_testdir
fakeroot ./debian/rules clean
debinst:
dh_testdir
cd .. && sudo dpkg -i $(PKGFILES)
lintian:
dh_testdir
cd .. && lintian -i $(PKGFILES)
upload:
dh_testdir
cd .. && grep -q 'PGP SIGNED MESSAGE' $(CHANGES) && dupload $(CHANGES)
|