1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
|
%:
dh $@ --with python2 --buildsystem=python_distutils
override_dh_auto_build:
dh_auto_build
ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS)))
PYTHONPATH=.. $(MAKE) -C doc html
-rm doc/build/html/_static/jquery.js doc/build/html/_static/underscore.js
endif
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
set -e; for PY in python2.6 $(shell pyversions -r); do \
[ $${PY
echo "I: Running Neo unittests using $$PY"; \
NOSETESTS_NO_NETWORK=1 $$PY /usr/bin/nosetests -s -v neo ;\
done
endif
override_dh_clean:
dh_clean
rm -rf neo.egg-info
rm -rf doc/build
|