1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409
|
Author: Tomas Berndtsson <tomas@nocrew.org> vim:ft=diff:
Description: Add multi game support with scoring
Index: b/curses.c
===================================================================
--- a/curses.c
+++ b/curses.c
@@ -201,6 +201,8 @@ ExtFunc void InitScreen(int scr)
for (y = boardVisible[scr] - 1; y >= 0; --y) {
move(boardYPos[scr] - y, boardXPos[scr] - 1);
addch('|');
+ for (x = boardWidth[scr] - 1; x >= 0; --x)
+ addstr(" ");
move(boardYPos[scr] - y, boardXPos[scr] + 2 * boardWidth[scr]);
addch('|');
}
@@ -256,6 +258,23 @@ ExtFunc void PlotUnderline(int scr, int
ExtFunc void ShowDisplayInfo(void)
{
+ move(statusYPos - 3, statusXPos);
+ printw("Won: %3d", won);
+ move(statusYPos - 2, statusXPos);
+ printw("Lost: %3d", lost);
+
+ move(statusYPos - 1, statusXPos);
+ switch(gameState) {
+ case STATE_WAIT_CONNECTION:
+ addstr("Waiting for opponent... ");
+ break;
+ case STATE_WAIT_KEYPRESS:
+ addstr("Press the key for a new game.");
+ break;
+ default:
+ addstr(" ");
+ }
+
move(statusYPos - 9, statusXPos);
printw("Seed: %d", initSeed);
clrtoeol();
Index: b/netris.h
===================================================================
--- a/netris.h
+++ b/netris.h
@@ -65,7 +65,7 @@ typedef long netint4;
#define DEFAULT_PORT 9284 /* Very arbitrary */
-#define DEFAULT_KEYS "jkl mspf^l"
+#define DEFAULT_KEYS "jkl mspf^ln"
/* Protocol versions */
#define MAJOR_VERSION 1
@@ -152,6 +152,13 @@ typedef struct _ShapeOption {
typedef int (*ShapeDrawFunc)(int scr, int y, int x,
BlockType type, void *data);
+enum States {
+ STATE_STARTING,
+ STATE_PLAYING,
+ STATE_WAIT_CONNECTION,
+ STATE_WAIT_KEYPRESS
+};
+
EXT GameType game;
EXT int boardHeight[MAX_SCREENS];
EXT int boardVisible[MAX_SCREENS], boardWidth[MAX_SCREENS];
@@ -167,6 +174,9 @@ EXT long stepDownInterval, speed;
EXT int myFlags, opponentFlags;
+EXT int won, lost;
+EXT enum States gameState;
+
EXT char scratch[1024];
extern ShapeOption stdOptions[];
Index: b/util.c
===================================================================
--- a/util.c
+++ b/util.c
@@ -74,7 +74,7 @@ ExtFunc void Usage(void)
" -p <port> Set port number (default is %d)\n"
" -k <keys> Remap keys. The argument is a prefix of the string\n"
" containing the keys in order: left, rotate, right, drop,\n"
- " down-faster, toggle-spying, pause, faster, redraw.\n"
+ " down-faster, toggle-spying, pause, faster, redraw, new.\n"
" \"^\" prefixes controls. (default is \"%s\")\n"
" -i <sec> Set the step-down interval, in seconds\n"
" -r <robot> Execute <robot> (a command) as a robot controlling\n"
Index: b/game.c
===================================================================
--- a/game.c
+++ b/game.c
@@ -28,11 +28,11 @@
#include <netinet/in.h>
enum { KT_left, KT_rotate, KT_right, KT_drop, KT_down,
- KT_toggleSpy, KT_pause, KT_faster, KT_redraw, KT_numKeys };
+ KT_toggleSpy, KT_pause, KT_faster, KT_redraw, KT_new, KT_numKeys };
static char *keyNames[KT_numKeys+1] = {
"Left", "Rotate", "Right", "Drop", "Down", "ToggleSpy", "Pause",
- "Faster", "Redraw", NULL };
+ "Faster", "Redraw", "New", NULL };
static char *gameNames[GT_len] = { "OnePlayer", "ClassicTwo" };
@@ -40,6 +40,10 @@ static char keyTable[KT_numKeys+1];
static int dropModeEnable = 0;
static char *robotProg;
+static int wonLast = 0;
+int lost = 0, won = 0;
+enum States gameState = STATE_STARTING;
+
ExtFunc void MapKeys(char *newKeys)
{
int i, k, ch;
@@ -323,6 +327,7 @@ ExtFunc void OneGame(int scr, int scr2)
break;
case E_lostRobot:
case E_lostConn:
+ wonLast = 1;
goto gameOver;
default:
break;
@@ -350,14 +355,17 @@ ExtFunc void OneGame(int scr, int scr2)
SendPacket(NP_giveJunk, sizeof(data), data);
}
}
+ wonLast = 0;
+
gameOver:
SetITimer(0, 0);
}
ExtFunc int main(int argc, char **argv)
{
- int initConn = 0, waitConn = 0, ch;
+ int initConn = 0, waitConn = 0, ch, done = 0;
char *hostStr = NULL, *portStr = NULL;
+ MyEvent event;
standoutEnable = colorEnable = 1;
stepDownInterval = DEFAULT_INTERVAL;
@@ -422,112 +430,139 @@ ExtFunc int main(int argc, char **argv)
if (fairRobot && !robotEnable)
fatal("You can't use the -F option without the -r option");
InitUtil();
- if (robotEnable)
- InitRobot(robotProg);
- InitNet();
InitScreens();
- if (initConn || waitConn) {
- MyEvent event;
-
- game = GT_classicTwo;
- if (initConn)
- InitiateConnection(hostStr, portStr);
- else if (waitConn)
- WaitForConnection(portStr);
- {
- netint4 data[2];
- int major;
-
- data[0] = hton4(MAJOR_VERSION);
- data[1] = hton4(PROTOCOL_VERSION);
- SendPacket(NP_version, sizeof(data), data);
- if (WaitMyEvent(&event, EM_net) != E_net)
- fatal("Network negotiation failed");
- memcpy(data, event.u.net.data, sizeof(data));
- major = ntoh4(data[0]);
- protocolVersion = ntoh4(data[1]);
- if (event.u.net.type != NP_version || major < MAJOR_VERSION)
- fatal("Your opponent is using an old, incompatible version\n"
- "of Netris. They should get the latest version.");
- if (major > MAJOR_VERSION)
- fatal("Your opponent is using an newer, incompatible version\n"
- "of Netris. Get the latest version.");
- if (protocolVersion > PROTOCOL_VERSION)
- protocolVersion = PROTOCOL_VERSION;
- }
- if (protocolVersion < 3 && stepDownInterval != DEFAULT_INTERVAL)
- fatal("Your opponent's version of Netris predates the -i option.\n"
- "For fairness, you shouldn't use the -i option either.");
- {
- netint4 data[3];
- int len;
- int seed;
+ while(!done) {
+ if (robotEnable)
+ InitRobot(robotProg);
+ InitNet();
+ if (!initSeed)
+ SRandom(time(0));
+ if (initConn || waitConn) {
+ game = GT_classicTwo;
+ if(gameState != STATE_STARTING) {
+ gameState = STATE_WAIT_CONNECTION;
+ ShowDisplayInfo();
+ RefreshScreen();
+ }
+ if (initConn)
+ InitiateConnection(hostStr, portStr);
+ else if (waitConn)
+ WaitForConnection(portStr);
+ gameState = STATE_PLAYING;
+ ShowDisplayInfo();
+ RefreshScreen();
+ {
+ netint4 data[2];
+ int major;
+
+ data[0] = hton4(MAJOR_VERSION);
+ data[1] = hton4(PROTOCOL_VERSION);
+ SendPacket(NP_version, sizeof(data), data);
+ if (WaitMyEvent(&event, EM_net) != E_net)
+ fatal("Network negotiation failed");
+ memcpy(data, event.u.net.data, sizeof(data));
+ major = ntoh4(data[0]);
+ protocolVersion = ntoh4(data[1]);
+ if (event.u.net.type != NP_version || major < MAJOR_VERSION)
+ fatal("Your opponent is using an old, incompatible version\n"
+ "of Netris. They should get the latest version.");
+ if (major > MAJOR_VERSION)
+ fatal("Your opponent is using an newer, incompatible version\n"
+ "of Netris. Get the latest version.");
+ if (protocolVersion > PROTOCOL_VERSION)
+ protocolVersion = PROTOCOL_VERSION;
+ }
+ if (protocolVersion < 3 && stepDownInterval != DEFAULT_INTERVAL)
+ fatal("Your opponent's version of Netris predates the -i option.\n"
+ "For fairness, you shouldn't use the -i option either.");
+ {
+ netint4 data[3];
+ int len;
+ int seed;
- if (protocolVersion >= 3)
- len = sizeof(data);
- else
- len = sizeof(netint4[2]);
- if ((myFlags & SCF_setSeed))
- seed = initSeed;
- else
- seed = time(0);
- if (waitConn)
- SRandom(seed);
- data[0] = hton4(myFlags);
- data[1] = hton4(seed);
- data[2] = hton4(stepDownInterval);
- SendPacket(NP_startConn, len, data);
- if (WaitMyEvent(&event, EM_net) != E_net ||
- event.u.net.type != NP_startConn)
- fatal("Network negotiation failed");
- memcpy(data, event.u.net.data, len);
- opponentFlags = ntoh4(data[0]);
- seed = ntoh4(data[1]);
- if (initConn) {
- if ((opponentFlags & SCF_setSeed) != (myFlags & SCF_setSeed))
- fatal("If one player sets the random number seed, "
- "both must.");
- if ((myFlags & SCF_setSeed) && seed != initSeed)
- fatal("Both players have set the random number seed, "
- "and they are unequal.");
- if (protocolVersion >= 3 && stepDownInterval != ntoh4(data[2]))
- fatal("Your opponent is using a different step-down "
- "interval (-i).\nYou must both use the same one.");
- SRandom(seed);
+ if (protocolVersion >= 3)
+ len = sizeof(data);
+ else
+ len = sizeof(netint4[2]);
+ if ((myFlags & SCF_setSeed))
+ seed = initSeed;
+ else
+ seed = time(0);
+ if (waitConn)
+ SRandom(seed);
+ data[0] = hton4(myFlags);
+ data[1] = hton4(seed);
+ data[2] = hton4(stepDownInterval);
+ SendPacket(NP_startConn, len, data);
+ if (WaitMyEvent(&event, EM_net) != E_net ||
+ event.u.net.type != NP_startConn)
+ fatal("Network negotiation failed");
+ memcpy(data, event.u.net.data, len);
+ opponentFlags = ntoh4(data[0]);
+ seed = ntoh4(data[1]);
+ if (initConn) {
+ if ((opponentFlags & SCF_setSeed) != (myFlags & SCF_setSeed))
+ fatal("If one player sets the random number seed, "
+ "both must.");
+ if ((myFlags & SCF_setSeed) && seed != initSeed)
+ fatal("Both players have set the random number seed, "
+ "and they are unequal.");
+ if (protocolVersion >= 3 && stepDownInterval != ntoh4(data[2]))
+ fatal("Your opponent is using a different step-down "
+ "interval (-i).\nYou must both use the same one.");
+ SRandom(seed);
+ }
+ }
+ {
+ char *userName;
+ int len, i;
+
+ userName = getenv("LOGNAME");
+ if (!userName || !userName[0])
+ userName = getenv("USER");
+ if (!userName || !userName[0])
+ strcpy(userName, "???");
+ len = strlen(userName)+1;
+ if (len > sizeof(opponentName))
+ len = sizeof(opponentName);
+ SendPacket(NP_userName, len, userName);
+ if (WaitMyEvent(&event, EM_net) != E_net ||
+ event.u.net.type != NP_userName)
+ fatal("Network negotiation failed");
+ strncpy(opponentName, event.u.net.data,
+ sizeof(opponentName)-1);
+ opponentName[sizeof(opponentName)-1] = 0;
+ for (i = 0; opponentName[i]; ++i)
+ if (!isprint(opponentName[i]))
+ opponentName[i] = '?';
+ for (i = 0; opponentHost[i]; ++i)
+ if (!isprint(opponentHost[i]))
+ opponentHost[i] = '?';
}
+ OneGame(0, 1);
}
- {
- char *userName;
- int len, i;
-
- userName = getenv("LOGNAME");
- if (!userName || !userName[0])
- userName = getenv("USER");
- if (!userName || !userName[0])
- strcpy(userName, "???");
- len = strlen(userName)+1;
- if (len > sizeof(opponentName))
- len = sizeof(opponentName);
- SendPacket(NP_userName, len, userName);
- if (WaitMyEvent(&event, EM_net) != E_net ||
- event.u.net.type != NP_userName)
- fatal("Network negotiation failed");
- strncpy(opponentName, event.u.net.data,
- sizeof(opponentName)-1);
- opponentName[sizeof(opponentName)-1] = 0;
- for (i = 0; opponentName[i]; ++i)
- if (!isprint(opponentName[i]))
- opponentName[i] = '?';
- for (i = 0; opponentHost[i]; ++i)
- if (!isprint(opponentHost[i]))
- opponentHost[i] = '?';
+ else {
+ game = GT_onePlayer;
+ OneGame(0, -1);
+ }
+ if (wonLast) {
+ won++;
+ } else {
+ lost++;
+ WaitMyEvent(&event, EM_net);
+ }
+ CloseNet();
+ if (robotEnable) {
+ CloseRobot();
+ } else {
+ gameState = STATE_WAIT_KEYPRESS;
+ ShowDisplayInfo();
+ RefreshScreen();
+ while(getchar() != keyTable[KT_new])
+ ;
}
- OneGame(0, 1);
- }
- else {
- game = GT_onePlayer;
- OneGame(0, -1);
}
+
return 0;
}
Index: b/board.c
===================================================================
--- a/board.c
+++ b/board.c
@@ -36,6 +36,18 @@ static int oldFalling[MAX_SCREENS][MAX_B
ExtFunc void InitBoard(int scr)
{
+ int s,w,h;
+
+ for(s = 0 ; s < MAX_SCREENS ; s++)
+ for(h = 0 ; h < MAX_BOARD_HEIGHT ; h++)
+ for(w = 0 ; w < MAX_BOARD_WIDTH ; w++) {
+ board[s][h][w] = 0;
+ oldBoard[s][h][w] = 0;
+ changed[s][h] = 0;
+ falling[s][w] = 0;
+ oldFalling[s][w] = 0;
+ }
+
boardHeight[scr] = MAX_BOARD_HEIGHT;
boardVisible[scr] = 20;
boardWidth[scr] = 10;
|