File: changelog

package info (click to toggle)
netscape4.77 4.77-2
  • links: PTS
  • area: non-free
  • in suites: potato, woody
  • size: 27,132 kB
  • ctags: 63
  • sloc: sh: 1,927; makefile: 319
file content (180 lines) | stat: -rw-r--r-- 7,257 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
netscape4.77 (4.77-2) stable unstable; urgency=high

  * Change default build from libc5 to libc6, fixing empty packages
    (closes: #94657)

 -- Ryan Murray <rmurray@debian.org>  Fri, 20 Apr 2001 16:28:01 -0700

netscape4.77 (4.77-1) stable unstable; urgency=high

  * New upstream (security) release (closes: #93613)
  * Change dependencies in Arch: all packages on Arch-Specific packages to be
    recommends instead.  This makes the Arch: all packages installable on
    all architectures. (closes: #66350)
  * Call bash on re-exec of debian/installer (closes: #79118)

 -- Ryan Murray <rmurray@debian.org>  Thu, 19 Apr 2001 00:37:50 -0700

netscape4.76 (4.76-1) stable unstable; urgency=high

  * To release manager: This fixes a segfault security bug, so should be
                        installed to stable as well.
  * Fix locales dependancies (closes: #72670, #75414)
  * Fix Japanese shortcut (closes: #71255)
  * Update Japanese translation (closes: #77678)
  * Update Korean resources (closes: #72896)
  * Remove DEBHELPER tokens that are being done by shell (closes: #71614)
  * New upstream version (closes: #77764)
  * Updated alternatives maintenance (closes: #74584, #47610, #65621)

 -- Ryan Murray <rmurray@debian.org>  Tue, 28 Nov 2000 20:07:54 -0800

netscape4.75 (4.75-2) stable unstable; urgency=high

  * Remove mailcap knowledge from netscape, as it caused too many problems.
    (closes: #69986, #70404)

 -- Ryan Murray <rmurray@debian.org>  Mon, 20 Nov 2000 17:24:26 -0800

netscape4.75 (4.75-1) stable unstable; urgency=high

  * New maintainer.
  * New upstream version which fixes a few security issues (closes: #67748)
    (closes: #68697, #68760, #67295, #64945, #64985, #64998, #65030, #68020)
  * Fix typo of mailcap (closes: #66592, #66381)
  * Merged in changes based on the test NMU of netscape4.73 (4.73-19.5)
    by Anthony Fok <foka@debian.org>:
     + CJK support:
       - Added Chinese, Japanese and Korean (CJK) Netscape resources. 
         Special thanks to the members of the Debian JP, Debian-KR, and
         Debian ZH Projects, especially Fumitoshi UKAI, Takuo KITAME,
         Masato Taruishi, UNO Takeshi and KiHyeon Seo.  Closes: #66633.
       - Added window manager menu entries for ja, ko, zh_CN and
         zh_TW.Big5.  These entries set the correct LANG, LC_CTYPE and
         LC_ALL.
       - Corrected Ryumin-Light-RKSJ-H PostScript font setting in the
         Japanese Netscape resource files.  (Thanks, Fumitoshi UKAI
         and OKAZAKI Tetsurou.)
    + Bug fixes:
       - The "$SHELL" string was missing in front of a "./my-install" call
         in debian/installer, which again resulted in a somewhat empty
         netscape-base-473.  Closes: #66108, #66689.
       - No longer creates empty /usr/X11R6/bin directory for the *-base-*
         packages.  Thanks to Thibaut Cousin for the report.  Close: #66108.
       - Added Build-Depends: debhelper, libstdc++2.9-glibc2.1, libxpm4,
         xlib6g, libc5, libg++27, xlib6, xpm4.7
       - Closing old non-bugs.  Closes: #56228, #56651, #56652.

 -- Ryan Murray <rmurray@debian.org>  Sun, 20 Aug 2000 11:36:14 -0700

netscape4.73 (4.73-19) frozen unstable; urgency=low

  * We haven't needed to predepend on netscape-base-4 for quite some
    time.
  * Added app-defaults to support chinese.  Txs Anthony Fok.  This also
    needed an update to the wrapper, so depend on netscape-base-4 >=
    1:4.73-31.  Closes: #64978.
  * Actually make the mailcap and mime.type symlinks.  Closes: #65187.

 -- Adam Heath <doogie@debian.org>  Tue, 20 Jun 2000 18:51:18 -0500

netscape4.73 (4.73-18) frozen unstable; urgency=low

  * I had to switch to DH_COMPAT=2 in the last build, and in so doing,
    forgot to update debian/installer.  This resulted in a somewhat
    empty netscape-base-473.  Closes: #64956(rc).

 -- Adam Heath <doogie@debian.org>  Wed, 31 May 2000 01:23:36 -0500

netscape4.73 (4.73-17) frozen unstable; urgency=low

  * New upstream release.  This fixes a security hole with the handling
    of SSL certificates.  Closes: #64257, #64650(rc).
  * Since this version includes high encryption, fortify no longer needs
    to be called in the postinst.  Closes: #60503, #63317.
  * The virtual package netscape-smotif-472-libc5 now depends on
    communicator-smotif-472-libc5.  Closes: #61881.
  * Set FAKEROOTKEY="" before calling dh_shlipdebs.  Closes: #61721.
  * Add symlinks in /usr/lib/netscape/<ver>/<bin> to /etc/mailcap and
    /etc/mime-types.  Closes: #52207, #62062.

 -- Adam Heath <doogie@debian.org>  Mon, 29 May 2000 01:21:20 -0500

netscape4.72 (4.72-16) frozen unstable; urgency=low

  * Fix depends on -libc5 virtual pkgs.  Closes: #60223.
  * Fix file overlap between -java- and -base-.  Closes: #60263.
  * The libc5 pkgs now depend on a libc5 netscape-base-4.  This should
    allow for a libc6 install with no libc5 support needed.

 -- Adam Heath <doogie@debian.org>  Sun, 26 Mar 2000 05:53:49 -0600

netscape4.72 (4.72-15) frozen unstable; urgency=low

  * SHELL=/bin/bash in debian/rules.
  * Created new {communic,navig}ator-smotif-libc5 debs, that contain
    the libc5 versions of netscape.  Also added a -libc5 version of
    the meta pkg.  The libc6 versions of the debs have no -libc6
    appended.  Closes: #45154, #45321, #47658, #47907, #49889, #50068,
    #51866, #48322.
  * Removed navigator-smotif-47 from the netscape-smotif-47 metapkg.
  * Don't strip netscape binaries.  Closes: #51534.

 -- Adam Heath <doogie@debian.org>  Thu,  2 Mar 2000 12:49:34 -0600

netscape4.7 (4.7-14) unstable; urgency=low

  * Change back to libc5 versions of netscape.  Should make it more
    stable.  Closes: #46777, #46995

 -- Adam Heath <doogie@debian.org>  Fri, 15 Oct 1999 13:20:53 -0500

netscape4.7 (4.7-13) unstable; urgency=low

  * I truly hate this.  I really do.  It just won't go away.  Why
    does java even exist at all, and why does it always give me a
    problem?
  * Add font.properties back in.  Fixes small java fonts.

 -- Adam Heath <doogie@debian.org>  Wed, 29 Sep 1999 22:45:48 -0500

netscape4.7 (4.7-12) unstable; urgency=low

  * New upstream release.

 -- Adam Heath <doogie@debian.org>  Tue, 28 Sep 1999 20:18:14 -0500

netscape4.61 (4.61-12) unstable; urgency=low

  * Postinst/prerm now handle symlinks for FSSTND compatibility.

 -- Adam Heath <doogie@debian.org>  Mon,  6 Sep 1999 07:06:44 -0500

netscape4.61 (4.61-11) unstable; urgency=low

  * Remove the version detection logic from the postinst, and always
    run update-alternatives. Closes: #43698

 -- Adam Heath <doogie@debian.org>  Mon, 30 Aug 1999 06:16:21 -0500

netscape4.61 (4.61-10) unstable; urgency=low

  * Use the libc5 versions from netscape, as they are much more stable
    then with the libc6 versions running against glibc 2.1.
  * Fixed java applet font problem(missing font.properties).

 -- Adam Heath <doogie@debian.org>  Fri, 27 Aug 1999 21:18:09 -0500

netscape4.61 (4.61-9) unstable; urgency=low

  * Rebuild for FHS compliance.
  * Run fortify in the postinst. Closes: #38725

 -- Adam Heath <doogie@debian.org>  Mon, 23 Aug 1999 05:44:32 -0500

netscape4.61 (4.61-8) unstable; urgency=low

  * Initial release.

 -- Adam Heath <doogie@debian.org>  Thu, 24 Jun 1999 13:34:40 -0500