File: test-requirements.txt

package info (click to toggle)
neutron-fwaas-dashboard 3.0.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 848 kB
  • sloc: python: 3,272; sh: 41; makefile: 35; javascript: 6
file content (19 lines) | stat: -rw-r--r-- 716 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.

# Hacking should appear first in case something else depends on pep8
hacking>=3.0,<3.1.0 # Apache-2.0

coverage!=4.4,>=4.0 # Apache-2.0
flake8-import-order==0.13 # LGPLv3
mock>=2.0.0 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.2;python_version>='3.4' # BSD
openstackdocstheme>=1.18.1 # Apache-2.0
reno>=2.5.0 # Apache-2.0

# integration tests requirements
selenium>=2.50.1 # Apache-2.0
xvfbwrapper>=0.1.3 #license: MIT
testtools>=2.2.0 # MIT