1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71
|
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --buildsystem=python_distutils --with python3,systemd
override_dh_auto_install:
echo "Do nothing..."
override_dh_auto_clean:
python3 setup.py clean
rm -f debian/*.init debian/*.service debian/*.upstart
override_dh_clean:
dh_clean
find . -type f -name "*.pyc" -delete
rm -rf build
override_dh_auto_test:
echo "Do nothing..."
override_dh_auto_build:
echo "Do nothing..."
override_dh_install:
rm -rf $(CURDIR)/debian/tmp
for i in $(PYTHON3S) ; do \
python$$i setup.py install --install-layout=deb --root $(CURDIR)/debian/tmp ; \
done
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
pkgos-dh_auto_test --no-py2 'neutron_lbaas\.tests\.unit\.(?!(.*test_synchronous_driver.TestHaproxyNSDriver.test_cleanup_name.*|.*test_v2_plugin_driver.TestLBaaSDriver.test_wf_created_on_first_member_creation.*|.*test_v2_plugin_driver.TestLBaaSDriverRestClient.test_flip_servers.*|.*common\.tls_utils\.test_cert_parser\.TestTLSParseUtils\.test_alt_subject_name_parses.*|.*drivers.radware\.test_v2_plugin_driver\.TestLBaaSDriverRestClient\.test_recover_was_called.*|.*agent\.test_agent\.TestLbaasService\.test_main.*|.*drivers\.haproxy\.test_jinja_cfg\.TestHaproxyCfg.*))'
endif
mkdir -p $(CURDIR)/debian/neutron-lbaas-common/etc/neutron
PYTHONPATH=$(CURDIR)/debian/tmp/usr/lib/python3/dist-packages oslo-config-generator \
--output-file $(CURDIR)/debian/neutron-lbaas-common/etc/neutron/lbaas_agent.ini \
--wrap-width 140 \
--namespace neutron.lbaas.agent \
--namespace oslo.log
pkgos-fix-config-default $(CURDIR)/debian/neutron-lbaas-common/etc/neutron/lbaas_agent.ini DEFAULT interface_driver openvswitch
PYTHONPATH=$(CURDIR)/debian/tmp/usr/lib/python3/dist-packages oslo-config-generator \
--output-file $(CURDIR)/debian/neutron-lbaas-common/etc/neutron/neutron_lbaas.conf \
--wrap-width 140 \
--namespace neutron.lbaas
PYTHONPATH=$(CURDIR)/debian/tmp/usr/lib/python3/dist-packages oslo-config-generator \
--output-file $(CURDIR)/debian/neutron-lbaas-common/etc/neutron/services_lbaas.conf \
--wrap-width 140 \
--namespace neutron.lbaas.service
pkgos-fix-config-default $(CURDIR)/debian/neutron-lbaas-common/etc/neutron/services_lbaas.conf service_providers service_provider LOADBALANCERV2:Haproxy:neutron_lbaas.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default
dh_install
dh_missing --fail-missing
override_dh_python3:
dh_python3 --shebang=/usr/bin/python3
override_dh_installcatalogs:
override_dh_installemacsen override_dh_installifupdown:
override_dh_installinfo override_dh_installmenu override_dh_installmime:
override_dh_installmodules override_dh_installlogcheck:
override_dh_installpam override_dh_installppp override_dh_installudev override_dh_installwm:
override_dh_installxfonts override_dh_gconf override_dh_icons override_dh_perl override_dh_usrlocal:
|