File: README.developers

package info (click to toggle)
nexus 4.3.2-svn1921-6
  • links: PTS, VCS
  • area: main
  • in suites: sid
  • size: 45,052 kB
  • sloc: java: 70,724; cpp: 34,810; ansic: 19,434; xml: 4,191; python: 4,123; f90: 2,326; fortran: 1,529; makefile: 1,105; sh: 809; tcl: 173; lisp: 169; pascal: 93; haskell: 27
file content (79 lines) | stat: -rw-r--r-- 2,113 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
Initial Setup
-------------

You first need to type:

    sh autogen.sh

to generate the initial configure and *.in files. You only need to 
type this again if you upgrade you system's versions of 
libtool/automake/autoconf and wish to use these newer version for the build

After doing this type:

    ./configure

For a full list of options that can be passed to configure type:

    ./configure --help

(typical configure options include the choice of compiler, enabling or
 disabling creation of bindings and the location of HDF libraries)

General Building
----------------

Just typing

    make

should be enough to build the NeXus libraries and executables from source. 
Make will automatically re-run configure if it needs to.
The test programs can then be run with

    make check

and everything installed onto the local system with

    make install

Making a distribution kit
-------------------------

To generate a *.tar.gz distribution kit just type:

    make distcheck

If you need to pass arguments to "configure" during the distcheck process,
you must add these to the DISTCHECK_CONFIGURE_FLAGS variable in Makefile.am

To generate an RPM install kit see README.rpm

Also see README.versions for setting nexus release versions

If you have problems
--------------------

If  autogen.sh  reports errors, it may be that you need
to install/upgrade your versions of autoconf, automake and libtool.
Source for these can be obtained from:

ftp://ftp.gnu.org/gnu/autoconf
ftp://ftp.gnu.org/gnu/automake
ftp://ftp.gnu.org/gnu/libtool

Most likely it will be autoconf that will need updating - NeXus
now requires autoconf 2.61 or above

NeXus Developer Mailing Lists
-----------------------------

SVN commit/log messages are automatically sent to the nexus-code-svn@nexusformat.org mailing list - if you wish to receive these, subscribe to the list via the link

  http://lists.nexusformat.org/mailman/listinfo/nexus-code-svn

Any general questions should be directed to nexus@nexusformat.org list - you can subscribe to this via the link

  http://lists.nexusformat.org/mailman/listinfo/nexus

$Id$