File: nginx-common.preinst

package info (click to toggle)
nginx 1.6.2-5+deb8u1~bpo70+1
  • links: PTS, VCS
  • area: main
  • in suites: wheezy-backports
  • size: 13,340 kB
  • sloc: ansic: 144,236; perl: 7,373; sh: 1,325; ruby: 789; makefile: 137; asm: 48; awk: 36; cpp: 18
file content (47 lines) | stat: -rw-r--r-- 1,285 bytes parent folder | download | duplicates (6)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
#!/bin/sh
set -e

# Handle naxsi removal
dpkg-maintscript-helper rm_conffile \
	  /etc/nginx/naxsi.rules         1.6.2-2~ -- "$@"
dpkg-maintscript-helper rm_conffile \
	  /etc/nginx/naxsi_core.rules    1.6.2-2~ -- "$@"
dpkg-maintscript-helper rm_conffile \
	  /etc/nginx/naxsi-ui.conf.1.4.1 1.6.2-2~ -- "$@"
dpkg-maintscript-helper rm_conffile \
	  /etc/nginx/naxsi-ui.conf       1.6.2-2~ -- "$@"

case "$1" in
  install)
    # If we are doing a fresh install, then these files are no longer needed.
    # They were around for a very short time and are best simply removed.
    rm -f /etc/logrotate.d/nginx-full
    rm -f /etc/logrotate.d/nginx-light
    rm -f /etc/logrotate.d/nginx-extras
    rm -f /etc/logrotate.d/nginx-common
    ;;

  upgrade)
    # If this is an upgrade, then they might have the UFW profile in the wrong spot.
    if [ -d /etc/ufw/applications.d/nginx ]; then
      rm -f /etc/ufw/applications.d/nginx/ufw.profile
      rmdir /etc/ufw/applications.d/nginx
    fi
    rm -f /etc/logrotate.d/nginx-full
    rm -f /etc/logrotate.d/nginx-light
    rm -f /etc/logrotate.d/nginx-extras
    rm -f /etc/logrotate.d/nginx-common
    ;;

  abort-upgrade)
    ;;

  *)
    echo "preinst called with unknown argument \`$1'" >&2
    exit 1
    ;;
esac

#DEBHELPER#

exit 0