File: changelog

package info (click to toggle)
nipype 1.1.1-2
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 16,204 kB
  • sloc: python: 141,047; tcl: 608; sh: 298; makefile: 177
file content (384 lines) | stat: -rw-r--r-- 13,507 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
nipype (1.1.1-2) unstable; urgency=medium

  * debian/control
    - point vcs fields to salsa
  * debian/patches/deb_simplify_requires temporary patch to resolve
    uninstallable state on older debian/ubuntus

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 09 Aug 2018 14:26:03 -0400

nipype (1.1.1-1) unstable; urgency=medium

  * Fresh upstream release
  * debian/control
    + python-concurrent.futures and python-pydot to B-Depends and 
      Depends for python-nipype

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 03 Aug 2018 13:00:43 -0400

nipype (1.0.3-1) unstable; urgency=medium

  * Fresh upstream release

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 15 May 2018 14:38:10 -0400

nipype (1.0.2-3) neurodebian; urgency=medium

  * debian/patches/deb_no_strict_versions
    - to allow for python-prov 1.4.0 and above
      see https://github.com/nipy/nipype/issues/2531
    - allow python-traits >= 4.5
      see https://github.com/nipy/nipype/issues/2346

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 09 Apr 2018 18:52:08 -0400

nipype (1.0.2-1) unstable; urgency=medium

  * New upstream release
  * debian/patches - refreshed
  * debian/control
    - added explicit dependency on python-dateutil (>= 2.2) as upstream
    - added python-pytest-xdist into bdepends since tests now use -n auto

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 28 Mar 2018 08:50:08 -0400

nipype (1.0.1-1) unstable; urgency=medium

  * Fresh upstream release
  * debian/control
    - added python-numpydoc to build-depends
  * debian/rules
    - export FSLOUTPUTTYPE=NIFTI_GZ to avoid useless warnings

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 28 Feb 2018 19:13:42 -0500

nipype (1.0.0+git69-gdb2670326-1) unstable; urgency=medium

  * Fresh upstream post-release snapshot
  * debian/control
    - upstream requires traits 4.5.0:
      https://github.com/nipy/nipype/issues/2346

 -- Yaroslav Halchenko <debian@onerussian.com>  Sun, 11 Feb 2018 00:10:19 -0500

nipype (0.14.0-1) unstable; urgency=medium

  * Fresh upstream release
    - dropped debian/patches/up*
    - should not FTBFS any longer (Closes: #848777)
  * debian/control
    - boosted debhelper to 9
    - boosted debian policy to 4.1.2
    - added python-packaging to build-depends and depends
    - downgraded cfflib to Recommends and removed from B-Depends
      (no longer developed etc)
  * debian/patches
    - make sphinx.ext.imgmath optionally needed

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 19 Dec 2017 14:14:49 -0500

nipype (0.13.1-1) experimental; urgency=medium

  * Fresh upstream release
    - switched to use py.test instead of nosetests
  * debian/control
    - added python-click and python-configparser
  * Dropped debian/patches/changeset_bf-install-use-resources.diff
    since upstream migrated to setuptools and issue with permissions
    should be resolved (see https://github.com/nipy/nipype/pull/1565)
  * debian/rules 
    - set LC_ALL=C.UTF-8 while building docs

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 23 May 2017 10:03:04 -0400

nipype (0.12.1+git4-gbc3a0b5-1) unstable; urgency=medium

  * New upstream snapshot from 0.12.0-53-g356319b -- there were a number of
    fixes after release, without visible major new features introduced),
    thus snapshot was chosen
  * debian/control
    - python-{funcsigs,future,mock,prov,psutil} added to
      {Build-,}Depends/Recommends
    - boosted policy to 3.9.8
  * debian/patches
    - refreshed
    - deb_robust_apidocgen added to guarantee robust doc generations even
      externals puke on import for some reason (like nitime atm)
      (Closes: #802409)
  * debian/rules
    - adjusted to find installed nipype under any -packages

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 04 Aug 2016 22:07:30 -0400

nipype (0.11.0-1) unstable; urgency=medium

  * Fresh upstream release
  * debian/rules
    - skip test_mesh_ops since needs X and also seems to be incompatible
      with our mayavi2 4.3.1 (https://github.com/nipy/nipype/issues/1218)
    - needed to drop --with-doctest so that test_mesh_ops doesn't get
      imported anyhow 
  * debian/control
    - recommend mayavi2 and python-xvfbwrapper as needed by some interfaces

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 15 Sep 2015 19:43:29 -0400

nipype (0.10.0-2) unstable; urgency=medium

  [ Andreas Tille ]
  * Team upload.
  * debian/blends, debian/upstream/metadata: Moved publication data where
    they belong to

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 28 Oct 2014 11:28:34 -0400

nipype (0.10.0-1) unstable; urgency=medium

  * New upstream release
    - provides non-minified javascript library (Closes: #737443)
  * debian/rules
    - enable doctests
    - switch away from pysupport
  * debian/control
    - boost policy to 3.9.6
    - build-depends on recent ipython (or use ipython1x) to obtain necessary
      sphinx extensions
    - use system-wide underscore.js
  * debian/copyright
    - updated years, and used BSD-3 for the short license label
  * debian/patches
    - deb_disable_google_online_snippets -- disable all kinds of Google
      goodness (CSE, analytics)
  * debian/*lintian*
    - adjusted
  * debian/patches
    - changeset_e4c5ba858abf0dde5739788c0174417d21fb4c41.diff
      to resolve issues with context handler on older numpy's

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 22 Oct 2014 21:32:32 -0400

nipype (0.9.2-1) unstable; urgency=low

  * New bugfix upstream release

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 31 Jan 2014 15:47:16 -0500

nipype (0.9.1+git9-g8b1d21c-1) unstable; urgency=low

  * Post bug-fix release snapshot
    - should fix DataFinder bug (gh-761) introduced in 0.9 (Closes: #734591)

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 08 Jan 2014 09:47:21 -0500

nipype (0.9-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - boosted policy to 3.9.4

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 20 Dec 2013 21:48:17 -0500

nipype (0.8-1) unstable; urgency=low

  * New upstream release
    - dropping picked up previously changesets

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 13 May 2013 14:47:28 -0400

nipype (0.7-1) experimental; urgency=low

  * New upstream release
  * debian/patches:
    - included post release fix
      changeset_fa7ef717b40cf175f0b6d09a3d2180cc9ddfb1e8.diff
    - dropped previous picked up patches
  * debian/watch:
    - adjusted for everchanging layout at github

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 10 Jan 2013 11:35:28 -0500

nipype (0.6.0-2) experimental; urgency=low

  * Cherry-picked cc5433b3513477a3ccf6addac4b67fb4e2884d48 as
    0001-fix-github-authentication.patch to resolve FTBFS while building
    documentation

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 23 Oct 2012 11:29:33 -0400

nipype (0.6.0-1) experimental; urgency=low

  * New upstream release.  Upload to experimental due to wheezy freeze
  * Boosted policy to 3.9.3
  * debian/watch: adjusted for github url changes

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 02 Jul 2012 09:41:29 -0400

nipype (0.5.3+git256-g493e708-1) UNRELEASED; urgency=low

  * New upstream snapshot from gh/master at 0.5.3-256-g493e708

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 26 Jun 2012 11:40:43 -0400

nipype (0.5.3-2) unstable; urgency=low

  * Make it buildable on HOMEless systems (Closes: #664944).
    Thanks Lucas Nussbaum for the report and Nicolas Bourdaud for the patch
    and Touko Korpela for the correction ;)

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 18 Jun 2012 13:41:47 -0400

nipype (0.5.3-1) unstable; urgency=low

  * Fresh bugfix upstream release (FIX: SPM model generation ...)

 -- Yaroslav Halchenko <debian@onerussian.com>  Sat, 31 Mar 2012 19:44:53 -0400

nipype (0.5.2-1) unstable; urgency=low

  * Fresh bugfix upstream release
  * Added debian/source/options to ignore difference in COMMIT_INFO.txt

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 14 Mar 2012 22:59:16 -0400

nipype (0.5.0-1) unstable; urgency=low

  * Fresh upstream release
    - dropped upstreamed patches up_recent_nipy_reference,
      deb_tollerate_exceptions_while_docbuilding
  * debian/copyright: updated to fit DEP-5 1.0 + copyright years
  * debian/python-nipype.lintian-overrides: extended list of 0-sized files

 -- Yaroslav Halchenko <debian@onerussian.com>  Sun, 04 Mar 2012 19:57:48 -0500

nipype (0.4.1-2) unstable; urgency=low

  * Cherry-picked post-release nipy-compatibility patch
    up_recent_nipy_reference (Closes: #638953). Thanks Barry for the reminder.

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 22 Sep 2011 14:20:05 -0400

nipype (0.4.1-1) unstable; urgency=low

  * Fresh upstream bugrelease -- all up_* patches absorbed/dropped from the
    quilt queue
  * pyversions: requires >= 2.6 now

 -- Yaroslav Halchenko <debian@onerussian.com>  Sat, 16 Jul 2011 17:43:23 -0400

nipype (0.4-1) unstable; urgency=low

  * Fresh upstream release
  * debian/source -- now 3.0 (quilt) format
  * debian/control:
    - boosted policy to 3.9.2 (no changes)
    - versioned *depends on traits (>=4.0) and nibabel (>=1.0)
    - added networkx (>=1.3) into Build-Depends
    - added python-cfflib into Build-Depends and Depends
    - added graphviz and ipython into Build-Depends -- needed to build
      documentation and run tests
  * debian/changelog -- updated for DEP5 rev 174
  * debian/watch -- was added to fetch tarballs from github
  * committed/absorbed from post-release upstream:
    - up_no_custom_matlab_path
    - up_some_no_fsl_skips
    - up_donot_fail_if_no_matlab
    - up_reset_results_when_crash
    - up_pipeline_clean_up_result_creation
  * introduced deb_tollerate_exceptions_while_docbuilding to avoid
    failures to build portions of documentation dependent on absent
    externals (e.g. FSL)
  * *Depends on backported python-traits4 as an alternative to
    python-traits >= 4.0
  * Assure no executable .csv files

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 15 Jul 2011 10:40:26 -0400

nipype (0.3.4-1) neurodebian; urgency=low

  * Added graphviz into recommends since 'dot' is also used directly by
    nipype (Closes: #604558)
  * Removed lipsia from Suggests (no relation really)
  * Added debian/blends with RFC822 reference to the poster
  * Replaced pynifti with nibabel. Removed copyright information on pynifti
  * Added additional build-depends (matplotlib, sympy, nibabel, nitime)
  * Moved networkx and nibabel into Depends since they are core components
  * Added suggests for pyxnat and matlab-spm8
  * Added .doc-base for the documentation integration
  * Updated debian/README* files
  * Assure use of Agg matplotlib backend while docbuilding/testing

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 22 Nov 2010 20:51:21 -0500

nipype (0.3.3-1) experimental; urgency=low

  * New upstream release
  * Included post release fix pushed upstream
    - python 2.5 compatibility: no keyword args after *args
  * Installing example code snippets within -doc package
  * Policy compliance boost to 3.9.1 -- no changes
  * Added 2 more lintian overrides for empty files

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 16 Sep 2010 22:34:49 -0400

nipype (0.3.3~dartmouth1-1) experimental; urgency=low

  * New upstream snapshot prepared for the nipype workshop at Dartmouth
    college

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 13 Sep 2010 23:44:36 -0400

nipype (0.3.2-1) unstable; urgency=low

  * New upstream release (bugfixes and documentation).
    + Issues fixed since 0.3 in FreeSurfer interface:
      - bugs in glmfit and concatenate
      - SegStats doctest
    + Documentation fixes/enhancements:
      - Developers howtos
      - misc docstrings

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 09 Aug 2010 14:07:46 -0400

nipype (0.3-1) unstable; urgency=low

  * New upstream release
  * Debian packaging
    - Moving packaging under NeuroDebian umbrella
    - Adjusting debian/copyright for DEP5 rev 135
    - Policy compliance boost to 3.9.0 -- BSD license provided verbatim
    - Added AFNI available from NeuroDebian repository into Suggests
    - Added build and runtime depends on python-traits
    - Added lintian overrides for empty testing .gz files

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 20 Jul 2010 18:25:24 -0400

nipype (0.2-4) unstable; urgency=low

  * BF: removed slipped in hardcoded 2.5 as version of Python (Closes:
    #571500).

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 25 Feb 2010 20:06:50 -0500

nipype (0.2-3) unstable; urgency=low

  * Moving python-networkx from Build-Depends into Build-Conflicts (versioned
    before 1.0~rc1) (Closes: #569401).

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 11 Feb 2010 17:12:16 -0500

nipype (0.2-2) unstable; urgency=low

  * Policy compliance boost to 3.8.4 -- no changes were necessary.
  * networkx moved into Recommends: due to outdated version of networkx
    in Debian (see #565319), networkx becomes optional dependency -- 
    corresponding commits cherry-picked from upstream trunk.

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 05 Feb 2010 22:22:47 -0500

nipype (0.2-1) experimental; urgency=low

  * Initial release (Closes: #550080)
  * Upload to experimental since python-networkx version only in the
  experimental atm.

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 04 Nov 2009 23:03:07 -0500