1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58
|
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
%:
dh $@ --buildsystem pybuild
ifneq (,$(filter terse,$(DEB_BUILD_OPTIONS)))
override_dh_auto_build:
dh_auto_build $@ -- --quiet
override_dh_auto_configure:
dh_auto_configure $@ -- --quiet
override_dh_auto_install:
dh_auto_install $@ -- --quiet
endif
ifeq (,$(filter terse,$(DEB_BUILD_OPTIONS)))
TEST_VERBOSE="_V="
endif
override_dh_auto_test:
if ! [ -d debian/original-pcx-files ]; then \
mkdir debian/original-pcx-files; \
mv regression/*.pcx debian/original-pcx-files; \
cp debian/fixed-pcx-files/*.pcx regression/; \
fi
PYTHONDONTWRITEBYTECODE=1 dh_auto_test --buildsystem makefile -- ${TEST_VERBOSE}
execute_after_dh_auto_clean:
make -C regression clean
if [ -d debian/original-pcx-files ]; then \
mv debian/original-pcx-files/*.pcx regression/; \
rmdir debian/original-pcx-files; \
fi
|