1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
|
COMPONENTS=core colors icons select
include /usr/share/dpkg/pkg-info.mk
%:
dh $@
override_dh_auto_build:
ln -s ../../packages/core node_modules/@blueprintjs/core || true
for p in `cat debian/nodejs/build_order`; do \
if test -e $$p; then \
(cd $$p && \
echo "Compiling $$p"; \
tsc -p src; \
tsc -p src -m commonjs --outDir lib/cjs; \
tsc -p src -t esnext --outDir lib/esnext \
); \
fi; \
done
override_dh_installdocs:
dh_installdocs
dh_nodejs_autodocs auto_dispatch
override_dh_gencontrol:
dh_gencontrol -pnode-blueprintjs-core -- -v$(DEB_VERSION)
dh_gencontrol -pnode-blueprintjs-popover2 -- \
-v$(shell pkgjs-pjson packages/popover2/ version)~$(DEB_VERSION)
dh_gencontrol -pnode-blueprintjs-select -- \
-v$(shell pkgjs-pjson packages/select/ version)~$(DEB_VERSION) \
|