1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83
|
include /usr/share/cdbs/1/rules/utils.mk
include /usr/share/cdbs/1/class/langcore.mk
include /usr/share/cdbs/1/rules/debhelper.mk
pkg = node-node-expat
libdir = /usr/lib/nodejs/node-expat
CDBS_BUILD_DEPENDS_rules_buildcore_config-guess-sub =
deps = nodejs, node-bindings, node-nan (>= 2.1.0)
bdeps = nodejs-dev, node-gyp, pkg-config, libexpat-dev
bdeps +=, node-debug, node-iconv, node-vows (>= 0.8.1)
CDBS_BUILD_DEPENDS +=, $(bdeps), $(deps)
CDBS_DEPENDS_$(pkg) = $(deps)
DEB_INSTALL_DOCS_$(pkg) += README.md
DEB_DH_INSTALL_ARGS_$(pkg) = package.json lib $(libdir)
DEB_COPYRIGHT_EXTRACT_EXTS = png
NOFAILTEST = | true
configure/$(pkg):: debian/stamp-node-gyp-configure
debian/stamp-node-gyp-configure:
node-gyp configure
touch $@
build/$(pkg):: debian/stamp-node-gyp-build
debian/stamp-node-gyp-build:
V=1 $(foreach flag,CC CXX CFLAGS CXXFLAGS CPPFLAGS LDFLAGS,\
$(flag)="$($(flag))") \
node-gyp build
$(if $(filter nocheck,$(DEB_BUILD_OPTIONS)),\
,\
vows --spec --no-color ./test/**/*.js$(NOFAILTEST))
touch $@
install/$(pkg)::
install -m 644 -D -t debian/$(cdbs_curpkg)$(libdir)/build/Release \
build/Release/*.node
dh_nodejs
cleanbuilddir::
[ ! -e debian/stamp-node-gyp-build ] || node-gyp clean
clean::
rm -f debian/stamp-node-gyp-*
# Node modules have an uncommon path and extension preventing
# autodetection by dh_shlibdeps or dh_fixperms, so we do it manually
binary-strip-IMPL/$(pkg)::
$(if $(is_debug_package)$(filter nostrip,$(DEB_BUILD_OPTIONS)),\
,\
find "$(cdbs_curdestdir)" -name "*.node" \
-exec strip \
--remove-section=.comment \
--remove-section=.note \
--strip-unneeded {} +)
binary-fixup/$(pkg)::
find "$(cdbs_curdestdir)" -name "*.node" -exec chmod -x {} +
binary-predeb-IMPL/$(pkg)::
find "$(cdbs_curdestdir)" -name "*.node" \
-exec dpkg-shlibdeps -Tdebian/$(cdbs_curpkg).substvars {} +
|