1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
|
%:
dh $@
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS) $(DEB_BUILD_PROFILES)))
tap -R spec test/*.js
else
@echo '**********************************************************'
@echo 'Skip test suite '
@echo '**********************************************************'
endif
override_dh_installexamples:
ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS) $(DEB_BUILD_PROFILES)))
dh_installexamples
find $(CURDIR)/debian/node-parents/usr/share/doc/node-parents/examples/ -name '*.js' -exec \
sed -i "s,require\s*[(]\s*'[.][.][^']*'\s*[)],require('parents'),g" {} \;
else
@echo '**********************************************************'
@echo 'Skip example '
@echo '**********************************************************'
endif
|