1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
|
include /usr/share/dpkg/pkg-info.mk
DEB_SUITE_EXP = $(filter experimental% UNRELEASED,$(DEB_DISTRIBUTION))
ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS)))
DOCS = README.html README.txt
endif
override_dh_auto_build: $(DOCS)
babeljs src -d lib
override_dh_auto_test:
NODE_ENV=test prove --verbose \
--exec "mocha --reporter=tap" \
test/*.js test/*/*.js $(if $(DEB_SUITE_EXP),|| true)
override_dh_installdocs:
dh_installdocs --all -- $(DOCS)
%.html: %.md
pandoc --from gfm-raw_html --to html --standalone --output $@ $<
%.txt: %.md
pandoc --from gfm-raw_html --to plain --output $@ $<
%:
dh $@
|