File: control

package info (click to toggle)
node-verror 1.10.0-1.1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 272 kB
  • sloc: javascript: 1,084; makefile: 13; sh: 2
file content (33 lines) | stat: -rw-r--r-- 1,065 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
Source: node-verror
Section: web
Priority: optional
Maintainer: Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Uploaders: Pirate Praveen <praveen@debian.org>
Build-Depends:
 debhelper (>= 9)
 , dh-buildinfo
 , nodejs
Standards-Version: 3.9.8
Homepage: https://github.com/davepacheco/node-verror
Vcs-Git: https://anonscm.debian.org/git/pkg-javascript/node-verror.git
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-javascript/node-verror.git

Package: node-verror
Architecture: all
Depends:
 ${misc:Depends}
 , nodejs
 , node-core-util-is (>= 1.0.2)
 , node-extsprintf (>= 1.2.0)
 , node-assert-plus (>= 1.0.0)
Description: rich JavaScript errors
 This module provides several classes in support of Joyent's Best Practices
 for Error Handling in Node.js.
 .
 The error classes here support:
  * printf-style arguments for the message
  * chains of causes
  * properties to provide extra information about the error
  * creating your own subclasses that support all of these
 .
 Node.js is an event-based server-side JavaScript engine.