File: autogen.sh

package info (click to toggle)
notify-osd 0.9.35+15.04.20150126-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid, stretch
  • size: 2,016 kB
  • ctags: 1,837
  • sloc: ansic: 17,819; python: 1,100; makefile: 457; cs: 335; sh: 103; xml: 48
file content (25 lines) | stat: -rwxr-xr-x 638 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#!/bin/sh
# Run this to generate all the initial makefiles, etc.

srcdir=`dirname $0`
test -z "$srcdir" && srcdir=.

PKG_NAME="notify-osd"
REQUIRED_AUTOCONF_VERSION=2.59
REQUIRED_AUTOMAKE_VERSION=1.8
REQUIRED_MACROS="python.m4"
ACLOCAL_FLAGS="$ACLOCAL_FLAGS -I m4"

(test -f $srcdir/configure.in) || {
    echo -n "**Error**: Directory "\`$srcdir\'" does not look like the"
    echo " top-level $PKG_NAME directory"
    exit 1
}

which gnome-autogen.sh || {
    echo "You need to install the gnome-common module and make"
    echo "sure the gnome-autogen.sh script is in your \$PATH."
    exit 1
}

USE_GNOME2_MACROS=1 . gnome-autogen.sh