File: ironic_api_version_opt_deprecated-50c9b0486e78fe6e.yaml

package info (click to toggle)
nova 2:14.0.0-4+deb9u1
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 33,804 kB
  • sloc: python: 315,557; sh: 1,317; xml: 1,184; pascal: 1,168; makefile: 126; sql: 43
file content (10 lines) | stat: -rw-r--r-- 585 bytes parent folder | download | duplicates (4)
1
2
3
4
5
6
7
8
9
10
---
deprecations:
  -  The configuration option ``api_version`` in the ``ironic`` group was
     marked as deprecated and will be removed in the future. The only
     possible value for that configuration was "1" (because Ironic only has 1
     API version) and the Ironic team came to an agreement that setting the API
     version via configuration option should not be supported anymore. As the
     Ironic driver in Nova requests the Ironic v1.8 API, that means that
     Nova 13.0.0 ("Mitaka") requires Ironic 4.0.0 ("Liberty") or newer if
     you want to use the Ironic driver.