1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45
|
%:
dh $@
override_dh_auto_configure:
dh_auto_configure --builddirectory=build -- --enable-static
override_dh_auto_build-arch:
dh_auto_build --builddirectory=build
override_dh_auto_install-arch:
dh_auto_install --builddirectory=build
override_dh_makeshlibs:
dh_makeshlibs -V
override_dh_strip:
dh_strip --ddeb-migration='libnpth0-dbg (<< 1.2-2~)'
WIN_FLAGS=LDFLAGS="-Xlinker --no-insert-timestamp" CFLAGS="-g -Os" CPPFLAGS=
override_dh_auto_build-indep:
for cpu in i686 x86_64; do \
mkdir -p build-$$cpu-w64-mingw32 && \
cd build-$$cpu-w64-mingw32 && $(WIN_FLAGS) ../configure \
--prefix=/usr/$$cpu-w64-mingw32 \
--with-prefix=/usr/$$cpu-w64-mingw32 \
--with-libgpg-error-prefix=/usr/$$cpu-w64-mingw32 \
--enable-static \
--host $$cpu-w64-mingw32 && \
$(WIN_FLAGS) $(MAKE) \
|| exit 1 ; \
cd .. ; \
done
override_dh_auto_install-indep:
for cpu in i686 x86_64; do \
cd build-$$cpu-w64-mingw32 && \
$(MAKE) install DESTDIR=$(shell pwd)/debian/tmp \
|| exit 1 ; \
cd .. ; \
done
|