1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49
|
DEB_BUILD_MAINT_OPTIONS = hardening=+all
DEB_CPPFLAGS_MAINT_APPEND = -D_XOPEN_SOURCE=600 -DNDEBUG
DPKG_EXPORT_BUILDFLAGS = 1
-include /usr/share/dpkg/buildflags.mk
ifneq (,$(findstring $(DEB_HOST_ARCH_OS), linux))
WITH_SYSTEMD = --enable-systemd
endif
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- \
--with-configdir=/etc/nsd \
--with-nsd_conf_file=/etc/nsd/nsd.conf \
--with-pidfile=/run/nsd/nsd.pid \
--with-dbfile=/var/lib/nsd/nsd.db \
--with-zonesdir=/etc/nsd \
--with-xfrdfile=/var/lib/nsd/xfrd.state \
--disable-largefile \
--disable-recvmmsg \
--enable-root-server \
--enable-mmap \
--enable-ratelimit \
$(WITH_SYSTEMD) \
--enable-checking \
--enable-dnstap \
override_dh_auto_install:
dh_auto_install
rmdir $(CURDIR)/debian/nsd/run/nsd
rmdir $(CURDIR)/debian/nsd/run
rmdir $(CURDIR)/debian/nsd/tmp
override_dh_install-arch:
dh_install -a
rm -f $(CURDIR)/debian/nsd/etc/nsd/nsd.conf.sample
override_dh_installchangelogs:
dh_installchangelogs doc/ChangeLog
override_dh_missing:
dh_missing --fail-missing
|