File: changelog

package info (click to toggle)
numpydoc 0.7.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 156 kB
  • ctags: 188
  • sloc: python: 1,383; makefile: 6
file content (82 lines) | stat: -rw-r--r-- 2,703 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
numpydoc (0.7.0-1) unstable; urgency=medium

  * Team upload

  [ Ghislain Antony Vaillant ]
  * Upgrade watch file to version 4
  * Switch from git-dpm to gbp
  * New upstream version 0.7.0
  * Add new build dependency on jinja2
  * Drop explicit dependency on Sphinx
  * Drop matplotlib from Suggests
  * No more repack required
  * Update copyright information
  * Use secure Source URI in copyright
  * Bump debhelper version to 10, no changes required
  * Bump standards version to 4.0.0, no changes required
  * Normalize the Vcs-Browser URI
  * Run DEP-8 tests for all Python versions
  * Add support for the nocheck build profile

 -- Ghislain Antony Vaillant <ghisvail@gmail.com>  Wed, 12 Jul 2017 19:12:11 +0100

numpydoc (0.6.0+ds1-1) unstable; urgency=medium

  * Team upload

  [ Ondřej Nový ]
  * Fixed VCS URL (https)

  [ Ghislain Antony Vaillant ]
  * Filter the vendored copy of sphinx.ext.linkcode from the upstream tarball
  * New upstream release
  * Update copyright file
  * Bump versioned depends on Python to 2.7 and 3.4
  * Bump standards version to 3.9.8, no changes required
  * Add autopkgtest testsuite for the packaging
  * Rearrange copyright paragraphs to fix Lintian warnings
  * Add missing build dependency on dh-python
  * Improve description of the Python 2 binary package
  * cme fix dpkg-control:
    - Drop versioned dependency on python-all
    - Drop versioned dependency on python[,3]-sphinx
    - Wrap and sort
  * cme fix dpkg-copyright: use HTTPS URI in Format field

 -- Ghislain Antony Vaillant <ghisvail@gmail.com>  Thu, 29 Dec 2016 13:46:10 +0000

numpydoc (0.5-2) unstable; urgency=medium

  * Update debian/copyright to mention all source files and license short
    names; switch to BSD license for the Debian packaging to be consistent
    with upstream (Closes: #803188).

 -- Denis Laxalde <denis@laxalde.org>  Wed, 28 Oct 2015 10:33:01 -0400

numpydoc (0.5-1) unstable; urgency=medium

  * Team upload.

  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

  [ Denis Laxalde ]
  * New upstream release (Closes: #801947).
  * Build python3 package as it's now supported upstream
  * debian/control:
    + Build-Depends on python-setuptools
    + Update Homepage (numpydoc is not anymore within numpy's source tree)
    + Update Standards-Version (no change needed)
  * debian/rules: use pybuild.
  * Drop clean-setup patch (included upstream)

  [ Barry Warsaw ]
  * debian/watch: Use the pypi.debian.net redirector.

 -- Barry Warsaw <barry@debian.org>  Tue, 27 Oct 2015 15:53:53 -0400

numpydoc (0.4-1) unstable; urgency=low

  * Initial release (Closes: #559916)

 -- Denis Laxalde <denis@laxalde.org>  Wed, 06 Jun 2012 15:20:20 -0400