File: changelog

package info (click to toggle)
nunit 2.6.4+dfsg-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 13,092 kB
  • ctags: 14,310
  • sloc: cs: 87,766; xml: 5,858; cpp: 512; sh: 198; makefile: 48; ansic: 8
file content (264 lines) | stat: -rw-r--r-- 9,936 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
nunit (2.6.4+dfsg-1) unstable; urgency=medium

  * [91d9c53] Imported Upstream version 2.6.4+dfsg
  * [165497e] ABI doesn't seem to have changed meaningfully, but the version
    number has been bumped. So include a policy file to handle redirecting
    2.6.3->2.6.4
  * [bd60cb0] NUnit's build system uses NAnt to build nuget files, using
    NAnt targets. Our NUnit avoids the NAnt dependency (as it would be
    circular), so manually override the NAnt paths. Also, our
    NUnit.Runners.nupkg is very cut down compared to upstream, due to all
    sorts of stuff we don't need being in it - so strip the install list.
    In addition, "nuget pack" is not path-separator-agnostic, so hardcode
    UNIX / instead of Windows \
  * [03d874c] Refreshed d/p/05_build_xml_doc_for_nunit.core.dpatch
  * [fc0727d] Refreshed d/p/use_default_framework.patch
  * [885695d] Build .nupkg files as nupkg-foo packages, placing the nupkg
    files in /usr/share/nupkg/ - this location can be used by adding
    file:///usr/share/nupkg as a source via the nuget command line
  * [d221357] Better dependencies for nupkgs
  * [b02ab20] Refreshed d/p/use_default_framework.patch
  * [8d704cc] Force XDG_CONFIG_HOME so /nonexistent/.config/NuGet isn't used

 -- Jo Shields <jo.shields@xamarin.com>  Mon, 14 Dec 2015 15:45:12 +0000

nunit (2.6.3+dfsg-1) unstable; urgency=medium

  * [c7bd1b5] Imported Upstream version 2.6.3+dfsg
  * [bcb4bf8] Move nunit-console-runner to GAC-installed libnunit2.6, 
    don't treat it as a private lib. This lib is signed, and treated 
    as a GAC lib by consumers such as MonoDevelop.
  * [7f08e99] Bump version to 2.6.3 as required
  * [84535eb] Refreshed patches
  * [8479f61] Split package up into per-assembly packages. This makes 
    ABI tracking easier in the future, as we can meaningfully have GAC 
    policy for cases where ABI isn't truly bumped, and no policy for 
    cases where it is. For example, if nunit.framework bumps ABI but 
    nunit.core does not, previously we would need to rebuild everything 
    using NUnit, but under the new split packaging, that rebuild would 
    not be needed for apps only using nunit.core.
  * [17a7dc7] Add missing nunit.mocks.dll to nunit.pc

 -- Jo Shields <directhex@apebox.org>  Tue, 16 Sep 2014 13:43:36 +0100

nunit (2.6.0.12051+dfsg-2) unstable; urgency=low

  * Upload to unstable.

 -- Jo Shields <directhex@apebox.org>  Sun, 27 May 2012 13:40:21 +0100

nunit (2.6.0.12051+dfsg-1) experimental; urgency=low

  * New upstream release

 -- Julian Taylor <jtaylor.debian@googlemail.com>  Sun, 15 Apr 2012 17:12:48 +0200

nunit (2.5.10.11092+dfsg-3) unstable; urgency=low

  [ Julian Taylor ]
  * [2d4a71e] add patch to fix monodevelop's nunit addin (LP: #889241)
  * [161ce71] build debug configuration

 -- Jo Shields <directhex@apebox.org>  Tue, 31 Jan 2012 09:22:46 +0000

nunit (2.5.10.11092+dfsg-2) unstable; urgency=low

  * Upload to unstable 

 -- Iain Lane <laney@debian.org>  Tue, 17 Jan 2012 22:20:17 +0000

nunit (2.5.10.11092+dfsg-1) experimental; urgency=low

  * [91dc8f1] update get-orig-source
  * [821bfe5] Imported Upstream version 2.5.10.11092+dfsg
  * [e1547c8] change to 3.0 (quilt)
  * [1d92bd0] remove obsolete nant patches 02-04
  * [5d79c0e] remove obsolete patches 06 and 07
  * [8518731] refresh 05_build_xml_doc_for_nunit.core.dpatch
  * [a26d39f] add patch to use default debian framework
  * [3be4a45] dh-7 rules
  * [90878b4] adapt install paths
  * [ea8e296] build and install docs
  * [b264abe] fix libmono2.4-cil install paths
  * [344973b] set api version in dh_makeclilibs
  * [8c64068] wrap-and-sort control
  * [542bf92] remove dpatch and nant b-d, add mono-xbuild
  * [1bdcae5] add misc:Depends
  * [cd7a4e2] fix permissions of dll's
  * [c9d153f] bump debhelper dep to >= 7.0.50~
  * [26e3baa] fix typo in description
  * [2791b43] rename libnunit2.4-cil -> libnunit2.5-cil
  * [5b55e0d] move libnunit2.5-cil to cli-mono section as per ftpmaster override
  * [bfc6351] fix core.interfaces install
  * [d9eb65f] build and install uiexception.dll
  * [99a8289] bump standard to 3.9.2, no further changes required
  * [9191fb8] delete the obsolete patches
  * [217698b] add me to uploaders
  * [bbcd491] remove DM-Upload-Allowed flag
  * [fba061f] convert copyright to DEP5 format and sync license text with upstreams
  * [3f47220] update pkg-config file to 2.5 libs

 -- Julian Taylor <jtaylor.debian@googlemail.com>  Sun, 03 Jul 2011 16:11:47 +0100

nunit (2.4.7+dfsg-6) unstable; urgency=medium

  [ Jelmer Vernooij ]
  * Remove myself from uploaders.

  [ Jo Shields ]
  * debian/monodoc-nunit-manual.postinst,
    debian/monodoc-nunit-manual.prerm:
    + Delete, since this is handled by triggers now (Closes: #591600)

 -- Jo Shields <directhex@apebox.org>  Wed, 18 Aug 2010 22:35:48 +0100

nunit (2.4.7+dfsg-5) unstable; urgency=low

  * debian/control,
    debian/nunit.pc,
    debian/libnunit2.4-cil.install,
    debian/libnunit-cil-dev.install:
    + Add new unversioned -dev package containing pkg-config file
  * debian/control:
    + No-change bump to Standards 3.8.3
    + Remove individual library build-depends, and add a build-depend
      on mono-devel 2.4.3 to ensure they're all present
  * debian/libnunit2.4-cil.install,
    debian/libnunit2.4-cil.installcligac,
    debian/nunit.pc:
    + CLI Policy 0.7 install location

 -- Jo Shields <directhex@apebox.org>  Fri, 20 Nov 2009 16:19:12 +0000

nunit (2.4.7+dfsg-4) unstable; urgency=medium

  * debian/patches/06_use_default_encoding.dpatch:
    + Don't explicitely set an encoding. (Closes: #530460)
  * debian/patches/07_disable_trace_listener.dpatch:
    + Disable the trace listener. (Closes: #500952)
  * debian/rules:
    + Updated monodoc commands with mdoc. (Closes: #531906)

 -- Mirco Bauer <meebey@debian.org>  Thu, 27 Aug 2009 23:12:18 +0200

nunit (2.4.7+dfsg-3) unstable; urgency=low

  [ Jo Shields ]
  * Update for Mono 2.0 transition, as much as nant allows such things

  [ Mirco Bauer ]
  * debian/control:
    + Removed mono-devel build-dep as nant takes care of that.
    + Bumped versioned build-dep of nant to >= 0.85.dfsg1-6, to ensure we get
      a transitioned version.

 -- Jo Shields <directhex@apebox.org>  Wed, 04 Mar 2009 21:35:55 +0100

nunit (2.4.7+dfsg-2) unstable; urgency=low

  * Fix typo in nunit-2.4.pc.
  * Bump policy version to 3.8.0.
  * Mangle version in debian/watch to cope with dfsg in version string.
  * Add nunit interfaces dll to pkg-config file.

 -- Jelmer Vernooij <jelmer@samba.org>  Sat, 14 Jun 2008 15:34:16 +0200

nunit (2.4.7+dfsg-1) unstable; urgency=low

  [ Jelmer Vernooij ]
  * New upstream release.
  * Set homepage and Vcs-Svn fields.
  * Change maintainer to Debian CLI Libraries Team. (Closes: #458551)
  * Allow Debian Maintainer uploads.

  [ Mirco Bauer ]
  * The "get sexy and ready for lenny" release
  * DFSG version of nunit 2.4.7
    (deleted all pre-compiled binaries from the tarball)
    + For the record here a list of the deleted files:
      tools/fit/fit.dll
      tools/fit/runFile.exe
  * debian/control:
    + Updated cli-common-dev build-dependency to >= 0.5.7
      (needed for cli.make)
    + Added new package monodoc-nunit-manual.
    + Added dpatch to build-dependencies.
    + Added myself to uploaders.
    + Fixed usage of the ".NET" term in package descriptions.
    + Moved conflicts libununit-cil to replaces, as it only overwrites the
      pkg-config file.
    + Added mono-2.0-devel, monodoc-base and libmono-system-runtime2.0-cil to
      build dependencies.
  * debian/compat:
    + Bumped to 7
  * debian/rules:
    + Include /usr/share/cli-common/cli.make
    + Migrated to debhelper v7 minimalistic style.
    + Bumped clilibs to 2.4.7
    + Build targets CLI 2.0 now, as most applications are 2.0 already.
  * debian/nunit-console.install
    debian/nunit-console.manpages
    debian/nunit-gui.install:
    + Converted some debian/rules calls to debhelper files.
  * debian/monodoc-nunit-manual.install
    debian/monodoc-nunit-manual.postinst
    debian/monodoc-nunit-manual.prerm:
    + New package.
  * debian/nunit.core.source
    debian/nunit.framework.source:
     + Files needed by monodoc.
  * debian/libnunit2.4-cil.links:
     + Added nunit.pc -> nunit-2.4.pc symlink.
  * debian/patches/03_disable_building_fit_fixtures.dpatch:
    + DFSG version of nunit doesn't contain the FIT library, thus we have to
      disable the fit test-fixtures.
  * debian/patches/05_build_xml_doc_for_nunit.core.dpatch:
    + Enable creating XML documentation for the nunit.core library
      (needed for monodoc API docs).
  * debian/patches/04_enable_building_gui_runner.dpatch:
    + Build nunit GUI runner for Mono.

 -- Mirco Bauer <meebey@debian.org>  Sun, 01 Jun 2008 13:00:34 +0200

nunit (2.2.9-1) unstable; urgency=low

  * New upstream release.

 -- Jelmer Vernooij <jelmer@samba.org>  Wed, 21 Feb 2007 20:59:37 +0100

nunit (2.2.8-2) unstable; urgency=low

  * Build mono-2.0 binaries.
  * Add policy file to indicate compatibility with 2.2.7.
  * Add binary package nunit-gui.

 -- Jelmer Vernooij <jelmer@samba.org>  Tue, 20 Jun 2006 13:50:41 +0200

nunit (2.2.8-1) unstable; urgency=low

  * New upstream release.
  * Fix debian/watch file.
  * Make nunit-console conflict with libnunit-cil. (closes: #362619)

 -- Jelmer Vernooij <jelmer@samba.org>  Fri, 28 Apr 2006 18:25:59 +0200

nunit (2.2.7-1) unstable; urgency=low

  * New upstream release. (closes: #352192)
  * Update dir seperator patch to new release.

 -- Jelmer Vernooij <jelmer@samba.org>  Tue, 21 Feb 2006 01:39:34 +0100

nunit (2.2.6-1) unstable; urgency=low

  * New upstream release.
  * Update dir seperator patch to new release.

 -- Jelmer Vernooij <jelmer@samba.org>  Tue, 24 Jan 2006 12:09:05 +1300

nunit (2.2.0-1) unstable; urgency=low

  * Initial Release.
    (closes: Bug#311413)

 -- Jelmer Vernooij <jelmer@samba.org>  Mon, 30 May 2005 14:01:43 +0200