1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
|
include /usr/share/dpkg/pkg-info.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export QT_SELECT = qt5
export PLUGIN_NAME=$(shell echo ${DEB_SOURCE} | cut -d"-" -f2-)
export PLUGIN_DEST=debian/${DEB_SOURCE}/usr/lib/${DEB_TARGET_MULTIARCH}/obs-plugins
%:
dh $@
execute_before_dh_auto_configure:
if [ "$(shell hostname)" = "canopus" ]; then \
LINESUS=$(shell cat data/locale/en-US.ini | wc -l); \
LINESPT=$(shell cat data/locale/pt-BR.ini | wc -l); \
if [ "$$LINESUS" != "$$LINESPT" ]; then \
echo "ERROR: Translation to pt_BR is out of date."; \
exit 1; \
fi; \
fi
override_dh_auto_configure:
dh_auto_configure -- -DBUILD_OUT_OF_TREE=On \
-DLIB_OUT_DIR=lib/${DEB_TARGET_MULTIARCH}/obs-plugins \
-DDATA_OUT_DIR=share/obs/obs-plugins/${PLUGIN_NAME} \
-DLINUX_PORTABLE=Off
execute_after_dh_install-arch:
ls ${PLUGIN_DEST}/${PLUGIN_NAME}.so
|