File: changelog

package info (click to toggle)
ocaml-curses 1.0.3-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 684 kB
  • ctags: 1,166
  • sloc: ml: 2,850; ansic: 748; makefile: 151
file content (85 lines) | stat: -rw-r--r-- 2,659 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
ocaml-curses (1.0.3-3) unstable; urgency=low

  [ Stéphane Glondu ]
  * Team upload
  * Bump debhelper compat to 10
  * Update Vcs-*

  [ Sylvain Le Gall ]
  * Remove Sylvain Le Gall from uploaders

  [ Sven Joachim ]
  * Use TERMTYPE rather than TERMINAL in configure check, the latter is
    opaque in recent ncurses versions (Closes: #868599).

 -- Stéphane Glondu <glondu@debian.org>  Tue, 18 Jul 2017 20:29:29 +0200

ocaml-curses (1.0.3-2) unstable; urgency=low

  * Team upload.
  * Enable wide character support (Closes: #600897).
    - Use libncursesw5-dev instead of libncurses5-dev in Build-Depends.
  * Convert to 3.0 (quilt) source format
    - Use quilt instead of dpatch
    - Fix build-depends-on-obsolete-package dpatch
  * Fix debhelper-but-no-misc-depends
  * Bump Standards-Version to 3.9.2, no changes needed
  * Fix debian-rules-missing-recommended-target build-{arch,indep}
  * Fix duplicate-short-description
  * Fix by copyright-with-old-dh-make-debian-copyright s/(C)/©/.

 -- Mehdi Dogguy <mehdi@debian.org>  Thu, 05 Jan 2012 02:43:58 +0100

ocaml-curses (1.0.3-1) unstable; urgency=low

  * New upstream release (Closes: #528838, #550377)
  * Use dh-ocaml 0.9.1 features
  * Upgrade Standards-Version to 3.8.3 (README.source, section ocaml)
  * Add myself to Uploaders and set Maintainer to 'Debian OCaml
    Maintainers'
  * Clean up file left after build
  * Add .doc-base file for API documentation
  * Remove byte.dpatch, add run_autoconf.dpatch to create configure and
    config.h.in

 -- Sylvain Le Gall <gildor@debian.org>  Wed, 16 Dec 2009 23:49:58 +0000

ocaml-curses (1.0.2-3) unstable; urgency=low

  [ Stephane Glondu ]
  * Switch packaging to git.

  [ Samuel Mimram ]
  * Rebuild with OCaml 3.11.
  * Use dh-ocaml.
  * Update compat to 7.
  * Update standards version to 3.8.0.
  * Add Homepage field.

 -- Samuel Mimram <smimram@debian.org>  Sun, 01 Mar 2009 21:10:25 +0100

ocaml-curses (1.0.2-2) unstable; urgency=low

  * Using dpatch to handle patches.
  * Added byte.dpatch to really fix the FTBFS on non-native archs.

 -- Samuel Mimram <smimram@debian.org>  Wed, 10 Oct 2007 10:53:14 +0000

ocaml-curses (1.0.2-1) unstable; urgency=low

  * New upstream release.
  * Should build cleanly on non-native archs, closes: #442229.

 -- Samuel Mimram <smimram@debian.org>  Tue, 09 Oct 2007 12:04:37 +0000

ocaml-curses (1.0.1-2) unstable; urgency=low

  * Rebuild with OCaml 3.10.

 -- Samuel Mimram <smimram@debian.org>  Mon, 10 Sep 2007 02:06:50 +0200

ocaml-curses (1.0.1-1) unstable; urgency=low

  * Initial release, closes: #439711.

 -- Samuel Mimram <smimram@debian.org>  Mon, 27 Aug 2007 16:28:28 +0200