File: changelog

package info (click to toggle)
ocaml-dune 2.7.1-2
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye
  • size: 14,064 kB
  • sloc: ml: 70,777; lisp: 466; ansic: 241; sh: 209; makefile: 119; python: 38; cpp: 17; javascript: 6
file content (130 lines) | stat: -rw-r--r-- 3,823 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
ocaml-dune (2.7.1-2) unstable; urgency=medium

  * Cherry-pick upstream configure fix (Closes: #975894)

 -- Stéphane Glondu <glondu@debian.org>  Sat, 28 Nov 2020 11:08:20 +0100

ocaml-dune (2.7.1-1) unstable; urgency=medium

  [ Stéphane Glondu ]
  * New upstream release

  [ Debian Janitor ]
  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
    Repository-Browse.

 -- Stéphane Glondu <glondu@debian.org>  Tue, 24 Nov 2020 09:28:02 +0100

ocaml-dune (2.7.0-1) unstable; urgency=medium

  * New upstream release
  * Bump debhelper compat level to 13

 -- Stéphane Glondu <glondu@debian.org>  Sat, 22 Aug 2020 11:07:12 +0200

ocaml-dune (2.1.3-2) unstable; urgency=high

  * ocaml-dune breaks libsedlex-ocaml-dev (<< 2.1-4)

 -- Stéphane Glondu <glondu@debian.org>  Tue, 04 Feb 2020 13:48:19 +0100

ocaml-dune (2.1.3-1) unstable; urgency=medium

  * New upstream release (Closes: #949810)
    - drop jbuilder binary package
  * Build-depend on debhelper-compat
  * Bump Standards-Version to 4.5.0
  * Add Rules-Requires-Root: no

 -- Stéphane Glondu <glondu@debian.org>  Mon, 27 Jan 2020 09:15:36 +0100

ocaml-dune (1.11.0-2) unstable; urgency=medium

  * Apply patch supplied by upstream to fix FTBFS on armhf

 -- Stéphane Glondu <glondu@debian.org>  Fri, 09 Aug 2019 11:32:47 +0200

ocaml-dune (1.11.0-1) unstable; urgency=medium

  * New upstream release
  * Update debian/watch

 -- Stéphane Glondu <glondu@debian.org>  Fri, 09 Aug 2019 07:36:02 +0200

ocaml-dune (1.6.2-4) unstable; urgency=high

  * Upload to unstable
  * Update Vcs-*

 -- Stéphane Glondu <glondu@debian.org>  Sun, 04 Aug 2019 15:28:16 +0200

ocaml-dune (1.6.2-3) experimental; urgency=medium

  * Rename source and main binary package to "ocaml-dune" (Closes: #919953)
  * Bump debhelper compat level to 12
  * Bump Standards-Version to 4.4.0
  * Update Homepage

 -- Stéphane Glondu <glondu@debian.org>  Mon, 29 Jul 2019 14:35:34 +0200

dune (1.6.2-2) unstable; urgency=medium

  * Add Breaks+Replaces: whitedune (<< 0.30.10-2.2) (Closes: #919622)

 -- Stéphane Glondu <glondu@debian.org>  Fri, 18 Jan 2019 17:50:45 +0100

dune (1.6.2-1) unstable; urgency=medium

  * New upstream release
    - add new binary package libdune-ocaml-dev
  * Update debian/watch
  * Update Vcs-*
  * Bump Standards-Version to 4.2.1 (no changes)

 -- Stéphane Glondu <glondu@debian.org>  Sat, 08 Dec 2018 15:27:49 +0100

dune (1.0~beta20-1) unstable; urgency=medium

  * Team upload
  * New upstream version (2018-04-10)
    + Fix FTBFS on bytecode-only archs (Closes: #894088)
  * debian/rules: Keep libdir to /usr/lib/ocaml (Closes: #894545)
  * Bump Standards-Version to 4.1.4.
    No change required.
  * Switch to debhelper 11
  * Package transition to “Dune” (Closes: #896466)
    Upstream renamed the project

 -- Nicolas Braud-Santoni <nicolas@braud-santoni.eu>  Sat, 21 Apr 2018 12:59:57 +0200

jbuilder (1.0~beta19-1) unstable; urgency=medium

  * Team upload
  * New upstream release
    + Updated d/rules to call ./configure manually because it errors
      on extra arguments

 -- Andy Li <andy@onthewings.net>  Mon, 19 Mar 2018 15:21:27 +0800

jbuilder (1.0~beta18-1) unstable; urgency=medium

  * Team upload
  * New upstream release
    * Fix library builds on OCaml bytecode-only architectures
      (Closes: #881770)
  * Update d/jbuilder.opam-install and d/jbuilder.manpages
  * Bump Standards-Version to 4.1.3 (no changes)

 -- Andy Li <andy@onthewings.net>  Wed, 28 Feb 2018 16:36:09 +0800

jbuilder (1.0~beta14-1) unstable; urgency=medium

  * New upstream release

 -- Stéphane Glondu <glondu@debian.org>  Thu, 12 Oct 2017 10:18:46 +0200

jbuilder (1.0~beta11-1) unstable; urgency=medium

  * Initial release (Closes: #870130)

 -- Stéphane Glondu <glondu@debian.org>  Sun, 30 Jul 2017 10:53:53 +0200