1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
|
DESTDIR=$(CURDIR)/debian/tmp
include /usr/share/ocaml/ocamlvars.mk
export OCAMLFIND_DESTDIR=$(DESTDIR)/$(OCAML_STDLIB_DIR)
%:
dh $@ --with ocaml
.PHONY: override_dh_auto_configure
override_dh_auto_configure:
ocaml setup.ml -configure --prefix /usr --destdir '$(DESTDIR)' --docdir /usr/share/doc/libestring-ocaml-dev
.PHONY: override_dh_auto_build
override_dh_auto_build:
ocaml setup.ml -build
ocaml setup.ml -doc
.PHONY: override_dh_auto_test
override_dh_auto_test:
ocaml setup.ml -test
.PHONY: override_dh_auto_install
override_dh_auto_install:
mkdir -p '$(OCAMLFIND_DESTDIR)'
ocaml setup.ml -install
.PHONY: override_dh_install
override_dh_install:
dh_install --fail-missing
.PHONY: override_dh_auto_clean
override_dh_auto_clean:
-ocaml setup.ml -distclean
|