1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46
|
DESTDIR=$(CURDIR)/debian/tmp
include /usr/share/ocaml/ocamlvars.mk
OCAMLFIND_DESTDIR=$(DESTDIR)/$(OCAML_STDLIB_DIR)
export OCAMLFIND_DESTDIR
OCAMLFIND_LDCONF=ignore
export OCAMLFIND_LDCONF
ifeq ($(OCAML_HAVE_OCAMLOPT),yes)
CONF_OPTS=--enable-has-ocamlopt
else
CONF_OPTS=--disable-has-ocamlopt
endif
SETUP := ocaml -I +camlp-streams camlp_streams.cma setup.ml
%:
dh $@ --with ocaml
override_dh_auto_configure:
$(SETUP) -configure --prefix /usr --destdir '$(DESTDIR)' $(CONF_OPTS)
override_dh_auto_build:
$(SETUP) -build
$(SETUP) -doc
.PHONY: override_dh_auto_test
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
$(SETUP) -test
endif
override_dh_auto_install:
mkdir -p '$(DESTDIR)/usr/bin'
mkdir -p '$(OCAMLFIND_DESTDIR)'
$(SETUP) -install
override_dh_auto_clean:
$(SETUP) -distclean
|