File: configure.ac

package info (click to toggle)
ocaml-ladspa 0.1.4-1.1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 592 kB
  • ctags: 122
  • sloc: sh: 3,180; ansic: 389; ml: 212; makefile: 94
file content (20 lines) | stat: -rw-r--r-- 577 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
# check for one particular file of the sources 
AC_INIT([ocaml-ladspa],[0.1.4],[savonet-users@lists.sourceforge.net])

VERSION=$PACKAGE_VERSION
AC_MSG_RESULT([configuring $PACKAGE_STRING])

AC_BASE_CHECKS()

# LADSPA check
AC_CHECK_HEADER(ladspa.h, [], [AC_MSG_ERROR([Cannot find ladspa.h, please 
install the LADSPA_SDK, or put ladspa.h somewhere it can be found]);])

# substitutions to perform
AC_SUBST(VERSION)

# Finally create the Makefile and samples
AC_CONFIG_FILES([Makefile],[chmod a-w Makefile])
AC_CONFIG_FILES([src/META])
AC_CONFIG_FILES([src/Makefile])
AC_OUTPUT