File: INSTALL

package info (click to toggle)
ocaml-magic 0.7.3-5
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, jessie, jessie-kfreebsd, sid, squeeze, stretch, wheezy
  • size: 312 kB
  • ctags: 79
  • sloc: ansic: 219; ml: 120; makefile: 101; sh: 3
file content (25 lines) | stat: -rw-r--r-- 509 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
0. Perquisites

   You need

   * Ocaml (>= 3.07)
   * libmagic (the package libmagic-dev for Debian)

1. Compilation

   ./configure  to check for dependencies
   make         for the target(s) supported by your platform
   make byte    for the bytecode library
   make opt     for the native code library

2. Installation (requires ocamlfind)

   make install		install the library

3. Example

   make examples	compile examples

4. Documentation

   make doc		build the documentation in the doc sudirectory