File: control

package info (click to toggle)
ocaml-migrate-parsetree 1.7.3-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 3,004 kB
  • sloc: ml: 58,094; makefile: 120; sh: 9
file content (67 lines) | stat: -rw-r--r-- 2,140 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
Source: ocaml-migrate-parsetree
Section: ocaml
Priority: optional
Maintainer: Debian OCaml Maintainers <debian-ocaml-maint@lists.debian.org>
Uploaders: Andy Li <andy@onthewings.net>
Standards-Version: 4.5.0
Rules-Requires-Root: no
Build-Depends:
 debhelper-compat (= 13),
 ocaml-nox,
 ocaml-dune (>= 2),
 libppx-derivers-ocaml-dev,
 libresult-ocaml-dev,
 ocaml-compiler-libs,
 ocaml-findlib,
 dh-ocaml
Homepage: https://github.com/ocaml-ppx/ocaml-migrate-parsetree
Vcs-Browser: https://salsa.debian.org/ocaml-team/ocaml-migrate-parsetree
Vcs-Git: https://salsa.debian.org/ocaml-team/ocaml-migrate-parsetree.git

Package: libmigrate-parsetree-ocaml
Architecture: any
Depends:
 ${shlibs:Depends},
 ${misc:Depends},
 ${ocaml:Depends}
Provides:
 ${ocaml:Provides}
Recommends: ocaml-findlib
Description: Convert OCaml parsetrees between different major versions (Runtime library)
 This library converts between parsetrees of different OCaml versions.
 For each version, there is a snapshot of the parsetree and conversion
 functions to the next and/or previous version.
 .
 This package contains the runtime library.

Package: libmigrate-parsetree-ocaml-dev
Architecture: any
Depends:
 ${shlibs:Depends},
 ${misc:Depends},
 ${ocaml:Depends}
Provides:
 ${ocaml:Provides}
Breaks:
 ocaml-dune (<< 2)
Recommends: ocaml-findlib
Description: Convert OCaml parsetrees between different major versions (Development package)
 This library converts between parsetrees of different OCaml versions.
 For each version, there is a snapshot of the parsetree and conversion
 functions to the next and/or previous version.
 .
 This package contains the development library.

Package: libmigrate-parsetree-ocaml-doc
Section: doc
Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends}
Enhances: libmigrate-parsetree-ocaml-dev
Description: Documentation for ocaml-migrate-parsetree
 This library converts between parsetrees of different OCaml versions.
 For each version, there is a snapshot of the parsetree and conversion
 functions to the next and/or previous version.
 .
 This package contains documentation for ocaml-migrate-parsetree in html
 format.