File: rules

package info (click to toggle)
ocaml-migrate-parsetree 1.7.3-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 3,004 kB
  • sloc: ml: 58,094; makefile: 120; sh: 9
file content (25 lines) | stat: -rwxr-xr-x 696 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#!/usr/bin/make -f

DESTDIR=$(CURDIR)/debian/tmp
include /usr/share/ocaml/ocamlvars.mk

%:
	dh $@ --with ocaml

override_dh_auto_configure:

override_dh_auto_install:
	dune install --destdir=$(DESTDIR) --prefix=/usr --libdir=..$(OCAML_STDLIB_DIR)
	rm -f $(DESTDIR)/usr/doc/ocaml-migrate-parsetree/LICENSE.md

# Preprocess migrate_parsetree_versions.mli, which contains OCaml_OCAML_VERSION..
debian/preprocess-ocamldoc.sh:
	echo '#!/bin/sh' > "$@"
	echo 'sed -e "s/OCaml_OCAML_VERSION/OCaml_$(shell echo $(OCAML_ABI) | cut -d. -f1-2 | tr -d .)/g" "$$@"' >> "$@"
	chmod +x "$@"

override_dh_ocamldoc: debian/preprocess-ocamldoc.sh
# Broken as of 1.4.0-1
#	dh_ocamldoc -u "-pp $<"

override_dh_dwz: