File: changelog

package info (click to toggle)
ocaml-zarith 1.10-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 588 kB
  • sloc: ansic: 2,839; ml: 1,912; sh: 1,589; asm: 1,035; makefile: 80; perl: 54
file content (149 lines) | stat: -rw-r--r-- 4,689 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
ocaml-zarith (1.10-1) unstable; urgency=medium

  * New upstream release
  * Bump debhelper compat level to 13
  * Bump Standards-Version to 4.5.0

 -- Stéphane Glondu <glondu@debian.org>  Mon, 21 Sep 2020 18:58:31 +0200

ocaml-zarith (1.9.1-1) unstable; urgency=medium

  * New upstream release
  * Add myself to uploaders
  * Bump Standards-Version to 4.4.1
  * Build-depend on debhelper-compat
  * Add Rules-Requires-Root: no

 -- Stéphane Glondu <glondu@debian.org>  Mon, 20 Jan 2020 10:45:09 +0100

ocaml-zarith (1.8-1) unstable; urgency=medium

  * Team upload
  * New upstream release
  * Bump Standards-Version to 4.4.0
  * Bump debhelper compat level to 12

 -- Stéphane Glondu <glondu@debian.org>  Sun, 04 Aug 2019 05:32:26 +0200

ocaml-zarith (1.7-1) unstable; urgency=medium

  * New upstream release
  * Bump Standards-Version to 4.1.4, no changes required
  * Update Vcs-* fields

 -- Mehdi Dogguy <mehdi@debian.org>  Fri, 11 May 2018 13:25:12 +0200

ocaml-zarith (1.5-1) unstable; urgency=medium

  * Team upload
  * New upstream release
  * Switch upstream location to github
  * Update Vcs-*

 -- Stéphane Glondu <glondu@debian.org>  Fri, 22 Sep 2017 15:16:52 +0200

ocaml-zarith (1.4.1-2) unstable; urgency=medium

  * Team upload
  * Build plugin with -linkall (Closes: #854787)

 -- Stéphane Glondu <glondu@debian.org>  Wed, 22 Feb 2017 11:17:47 +0100

ocaml-zarith (1.4.1-1) unstable; urgency=medium

  * Team upload
  * New upstream release
  * Update Vcs-*
  * Bump debhelper compat to 9

 -- Stéphane Glondu <glondu@debian.org>  Tue, 26 Jan 2016 14:51:07 +0100

ocaml-zarith (1.3-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 3.9.6, no changes required.

 -- Mehdi Dogguy <mehdi@debian.org>  Fri, 31 Jul 2015 19:00:28 +0000

ocaml-zarith (1.2.1-2) unstable; urgency=low

  * Upstream provided test "test.b" has been renamed to "testb". Update
    debian/rules accordingly to fix FTBFS on bytecode architectures.

 -- Mehdi Dogguy <mehdi@debian.org>  Wed, 26 Jun 2013 21:41:53 +0200

ocaml-zarith (1.2.1-1) unstable; urgency=low

  * New upstream release
  * Make libzarith-ocaml-dev depend on libgmp3-dev. (Closes: #714088)
  * Fix outdated-autotools-helper-file config.guess
    * Add autotools-dev in Build-Depends
  * Bump Standards-Version to 3.9.4

 -- Mehdi Dogguy <mehdi@debian.org>  Tue, 25 Jun 2013 21:43:08 +0200

ocaml-zarith (1.1-2) unstable; urgency=low

  * Fix "make test" call: it should be "test" on native architectures
    and "test.b" on bytecode architectures.

 -- Mehdi Dogguy <mehdi@debian.org>  Tue, 15 May 2012 13:57:32 +0200

ocaml-zarith (1.1-1) unstable; urgency=low

  * New upstream release
    - Remove Debian patches (integrated by upstream).
    - ocamldoc is called with "-charset" command-line flag, which
      comes with OCaml 3.12.1. Update Build-Depends accordingly.
  * Bump Standards-Version to 3.9.3 (no changes needed).
  * Call "make test" before executing the test file.

 -- Mehdi Dogguy <mehdi@debian.org>  Tue, 15 May 2012 13:39:48 +0200

ocaml-zarith (1.0-6) unstable; urgency=low

  * Don't run test-suite if DEB_BUILD_OPTIONS contains "nocheck".
  * Add patch from upstream's repository:
    - 0007-Fixed-1-bit-precision-loss-when-converting-doubles-t.patch

 -- Mehdi Dogguy <mehdi@debian.org>  Sat, 24 Mar 2012 10:22:26 +0100

ocaml-zarith (1.0-5) unstable; urgency=low

  * Fix FTBFS on sparc
    - Add 0006-Use-memcpy-instead-of-cast-ing.patch

 -- Mehdi Dogguy <mehdi@debian.org>  Fri, 04 Nov 2011 14:41:46 +0100

ocaml-zarith (1.0-4) unstable; urgency=low

  * Release to unstable.
  * Remove 0002-Fix-install-target.patch and adapt debian/rules instead.

 -- Mehdi Dogguy <mehdi@debian.org>  Wed, 19 Oct 2011 18:06:17 +0200

ocaml-zarith (1.0-3) experimental; urgency=low

  * Do not try to build zarith.a on bytecode only architectures.
    - Update 0003-Make-it-byte-arch-aware.patch
  * Set CAML_LD_LIBRARY_PATH to $(CURDIR) before running test.b on
    bytecode only architectures.

 -- Mehdi Dogguy <mehdi@debian.org>  Wed, 05 Oct 2011 14:25:39 +0200

ocaml-zarith (1.0-2) experimental; urgency=low

  * Make ocamlopt's presence optional. This should prevent build failures
    on bytecode only architectures.
    - Add 0005-ocamlopt-is-not-really-required.patch
  * kfreebsd-amd64 and kfreebsd-i386 are also (resp.) amd64 and i386. Add
    some arch-triplets in configure script.
    - Add 0006-Detect-more-arch-triplets.patch

 -- Mehdi Dogguy <mehdi@debian.org>  Wed, 05 Oct 2011 09:03:52 +0200

ocaml-zarith (1.0-1) experimental; urgency=low

  * Initial release. (Closes: #643736)

 -- Mehdi Dogguy <mehdi@debian.org>  Thu, 29 Sep 2011 07:54:35 +0200