1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
|
Description: Fix o2image segfault on s390x
Use correct union member. On little endian this worked
because of the union layout.
Author: Valentin Vidic <vvidic@debian.org>
Forwarded: https://github.com/markfasheh/ocfs2-tools/pull/48
Last-Update: 2020-05-21
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
@@ -113,7 +113,7 @@
if (ret)
goto out;
} else {
- for (j = 0; j < (rec->e_int_clusters*ost->ost_bpc); j++)
+ for (j = 0; j < (rec->e_leaf_clusters*ost->ost_bpc); j++)
ocfs2_image_mark_bitmap(ofs,
(rec->e_blkno + j));
}
|