1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
|
export DEB_BUILD_MAINT_OPTIONS=hardening=+bindnow
%:
dh $@ --parallel --with autoreconf
.PHONY: override_dh_autoreconf
override_dh_autoreconf:
dh_autoreconf ./bootstrap
.PHONY: override_dh_auto_configure
override_dh_auto_configure:
dh_auto_configure -- --disable-debug --disable-update-database \
--enable-official-khronos-headers
.PHONY: override_dh_auto_test
override_dh_auto_test:
if ! dh_auto_test ; then \
cat tests/testsuite.log ; \
exit 1 ;\
fi
.PHONY: override_dh_shlibdeps
override_dh_shlibdeps:
dh_shlibdeps -a -- --warnings=7
.PHONY: override_dh_install
override_dh_install:
dh_install --fail-missing -XlibOpenCL.la
.PHONY: override_dh_installchangelogs
override_dh_installchangelogs:
dh_installchangelogs NEWS
.PHONY: override_dh_strip
override_dh_strip:
dh_strip --dbgsym-migration='ocl-icd-dbg (<< 2.2.10-2~)'
|