File: changelog

package info (click to toggle)
odin 2.0.4-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye
  • size: 8,992 kB
  • sloc: cpp: 62,419; sh: 4,466; makefile: 776
file content (292 lines) | stat: -rw-r--r-- 10,365 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
odin (2.0.4-3) unstable; urgency=medium

  * Team upload.
  * Configure build to target the libdir /usr/lib/$(DEB_HOST_MULTIARCH)/odin,
    and adjust install scripts to the new staging location: allows executables 
    provided by packages mitools and odin to find their private shared objects.
    Closes: #985577

 -- Étienne Mollier <etienne.mollier@mailoo.org>  Sat, 20 Mar 2021 13:49:44 +0100

odin (2.0.4-2) unstable; urgency=medium

  * Team upload.
  * Added mitools and qtchooser as dependency of libodin-dev; fixes broken
    symbolic links on libodin-dev installation.
    Closes: #985508

 -- Étienne Mollier <etienne.mollier@mailoo.org>  Fri, 19 Mar 2021 20:02:31 +0100

odin (2.0.4-1) unstable; urgency=medium

  * Team upload.
  * Take over package into Debian Med team maintenance
  * Standards-Version: 4.5.1 (routine-update)
  * debhelper-compat 13 (routine-update)
  * Add salsa-ci file (routine-update)
  * Rules-Requires-Root: no (routine-update)
  * Refer to specific version of license GPL-2+.
  * watch file standard 4 (routine-update)
  * Use dh-exec to install in Multiarch locations
  * Enable dh_missing --fail-missing
  * Fix typo in d/copyright
  * Remove debian/menu file
  * Remove outdated debian/TODO

 -- Andreas Tille <tille@debian.org>  Tue, 15 Dec 2020 21:11:56 +0100

odin (2.0.4-0.2) unstable; urgency=medium

  * Non-maintainer upload.
  * Remove qt5-default from build depends (Closes: #972166).
    - Export QT_SELECT := qt5 in order to let qtchooser use the right Qt version.

 -- Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>  Sun, 25 Oct 2020 14:58:22 -0300

odin (2.0.4-0.1) unstable; urgency=medium

  * Non-maintainer upload.
  * New upstream release.
    - Fixed the build on i386. (Closes: #953064)

 -- Adrian Bunk <bunk@debian.org>  Wed, 20 May 2020 23:12:09 +0300

odin (2.0.3-2) unstable; urgency=medium

  * Team upload.
  * Switch to Qt5
    Closes: #875065
  * debhelper-compat 9
  * Standards-Version: 4.4.1
  * Use secure URI in debian/watch.
  * Set upstream metadata fields: Archive.
  * DEP5

 -- Andreas Tille <tille@debian.org>  Wed, 20 Nov 2019 07:16:26 +0100

odin (2.0.3-1) unstable; urgency=medium

  * Team upload.
  * debhelper 9
  * Point Vcs fields to salsa.debian.org
  * Standards-Version: 4.3.0
  * Respect DEB_BUILD_OPTIONS in override_dh_auto_test target
  * Remove trailing whitespace in debian/changelog
  * Remove duplicated file debian/menu
  * Build-Depends: help2man (since this is used as test)
  * Re-activate patch to skip some tests that are failing for some
    unknown reason in a pbuilder chroot
  * Fix FTBFS with dcmtk >= 3.6.1~20170228-2 (thanks for the patch
    to Steve Langasek <steve.langasek@canonical.com>)
    Closes: #865955
  * libodin-dev: Depends: sensible-utils
  * hardening=+all
  * Build-Depends: s/libqwt5-qt4-dev/libqwt-dev/
    Closes: #909363

 -- Andreas Tille <tille@debian.org>  Sat, 19 Jan 2019 18:18:18 +0100

odin (2.0.3-0.1) unstable; urgency=medium

  * Non-maintainer upload.
    - drop gcc patches, upstream
  * New upstream release (Closes: #835746)

 -- Gianfranco Costamagna <locutusofborg@debian.org>  Fri, 10 Mar 2017 19:40:49 +0100

odin (2.0.2-0.3) unstable; urgency=medium

  * Non-maintainer upload.
  * Revert a little bit of the previous gcc-6-fix2.

 -- Gianfranco Costamagna <locutusofborg@debian.org>  Fri, 22 Jul 2016 13:58:23 +0200

odin (2.0.2-0.2) unstable; urgency=medium

  * Non-maintainer upload.
  * debian/patches/gcc-6-fix.patch:
    - upstream fix [r8688] for gcc-6 build failure:
  * debian/patches/gcc-6-fix2.patch:
    - fix for some other gcc-6 build failures:
      (Closes: #831181)

 -- Gianfranco Costamagna <locutusofborg@debian.org>  Fri, 15 Jul 2016 19:34:55 +0200

odin (2.0.2-0.1) unstable; urgency=medium

  * New upstream release, patch refresh
  * Non-maintainer upload.
  * Drop vtk6.3.patch, upstream.
  * d/rules fix testsuite with new dcmtk (Closes: #829607)

 -- Gianfranco Costamagna <locutusofborg@debian.org>  Mon, 04 Jul 2016 17:35:09 +0200

odin (2.0.1-0.2) unstable; urgency=medium

  * Non-maintainer upload.

  [ Gert Wollny ]
  * Build conflicts against qt5, to make sure
    it isn't picked up (Closes: #821133)
  * debian/patches/vtk6.3.patch: make the package build
    against vtk 6.3 (Closes: #821134)

  [ Thies Jochimsen ]
  * Add libhdf5-dev and libismrmrd-dev to build-dependencies,
    enabling ISMRMRD format (Closes: #821162).

  [ Gianfranco Costamagna ]
  * Enable ISMRMRD only where available (exclude armhf)

 -- Gianfranco Costamagna <locutusofborg@debian.org>  Fri, 15 Apr 2016 22:54:54 +0200

odin (2.0.1-0.1) unstable; urgency=medium

  * Non-maintainer upload.
  * New upstream release
    - vtk6 compatible.
  * Switch to vtk6 and drop hacks for includes file.
    (Closes: #798170)
  * drop gsl2 patch: upstream
  * drop old libblitz-dev and libgsl0-dev alternative dependencies
  * Bump debhelper and compat level to 9.
  * Bump std-version to 3.9.8
  * Fix insecure VCS uri.
  * Drop liboil* recommend, not in unstable/stretch anymore.
  * refresh ld-as-needed.patch
  * Update copyright years.

 -- Gianfranco Costamagna <locutusofborg@debian.org>  Thu, 14 Apr 2016 12:00:53 +0200

odin (1.8.8-2.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Fix dcmtk runtime dependencies
  [ Mattia Rizzolo ]
  * Fix dcmtk dependencies (Closes: #810945)

 -- Gianfranco Costamagna <locutusofborg@debian.org>  Thu, 14 Apr 2016 11:40:22 +0200

odin (1.8.8-2) unstable; urgency=medium

  * Switch to using dh-autoreconf. Thanks to Bas Couwenberg for the nudge.
  * Update build dependencies for GSL 2, change libgsl0-dev to libgsl-dev.
    Courtesy Bas Couwenberg (Closes: #805819).
  * Add patch for GSL 2 support. Courtesy Bas Couwenberg.
  * Adjust include paths for VTK 5.10.
  * Use libdcmtk-dev as primary build dependency, keep old package names
    as alternatives (Closes: #804572).
  * Likewise use libpng-dev as primary build-dependency, but keep libpng12-dev
    as an alternative (Closes: #662451).
  * Add patch to be able to build with ld --as-needed. Courtesy of Bhavani
    Shankar R (Closes: #770061).
  * Add explicit dependency to libdcmtk2 (no longer pull in via -dev package)
    to have dicom.dic available for the test suite.

 -- Michael Hanke <mih@debian.org>  Sun, 06 Dec 2015 08:53:29 +0100

odin (1.8.8-1) unstable; urgency=medium

  * New upstream release.
    - Supports blitz 0.10 (Closes: #680804).
  * Removed all patches -- merged upstream or obsolete.
  * Build using the default Debian build flags, hence enabled
    hardening.
  * Bumped Standards-version to 3.9.5, no changes necessary.

 -- Michael Hanke <mih@debian.org>  Thu, 09 Oct 2014 09:30:26 +0200

odin (1.8.5-2) unstable; urgency=low

  * Amend patch for GCC 4.7 compatibility with another missing header
    include. Thanks to Samuel Thibault for the report and Thies Jochimsen
    for the upstream fix (Closes: #673217).

 -- Michael Hanke <mih@debian.org>  Fri, 18 May 2012 09:39:29 +0200

odin (1.8.5-1) unstable; urgency=low

  * New upstream release.
    - Writing of multiple VTK files for dynamic data sets
    - Storing protocol together with z-maps in miview fMRI
    - Added dialect 'tcourse' to ASCII fileio
    - SeqSimMonteCarlo now supports multi-threaded simulation
    - Added gamma variate fitting function
    - Added filter steps 'quantilmask' and 'resample'
    - Filter steps 'minip', 'maxip' and 'proj' now with direction argument
    - Added option 'weightmask' to micalc
    - Added reco step 'qcspike' to detect spikes in signal
    - Added reco steps 'driftcalc/driftcorr' for correction of field drift
  * Bumped Standards-version to 3.9.3, no changes necessary.
  * No longer depends on liboil.
  * Remove obsolete patches (missing_header, gsl_roundoff) -- merged upstream.
  * Added patch from upstream SVN to fix missing header for GCC 4.7
    (Closes: #667307). Thanks to Matthias Klose for the report.

 -- Michael Hanke <mih@debian.org>  Sat, 07 Apr 2012 09:40:10 +0200

odin (1.8.4-2) unstable; urgency=low

  * Disable Vista data format support. Upstream will do this in 1.8.5, but it
    eases the libvia transition in Debian right now.
  * Removed DM-flag from debian/control -- no longer needed.

 -- Michael Hanke <mih@debian.org>  Mon, 05 Mar 2012 09:57:15 +0100

odin (1.8.4-1) unstable; urgency=low

  * New upstream release. Now compatible with DCMTK 3.6 (Closes: #623145).
  * Added patch to fix GSL 1.5 related problem, causing a unittest to
    segfault.
  * Add link libraries for a unresolved dependencies of DCMTK 3.6. This is a
    workaround, not a solution (see #628153).
  * Bumped Standards-version to 3.9.2, no changes necessary.

 -- Michael Hanke <mih@debian.org>  Fri, 16 Dec 2011 15:26:08 +0100

odin (1.8.3-1) unstable; urgency=low

  * New upstream release.
  * Change build-dependency from libblas-dev to libatlas-base-dev to ensure
    availability of lapack (Closes: #614447).
  * Updated maintainer email.
  * Bumped Standards-version to 3.9.1, no changes necessary.
  * Explicitly links against all required libs to address changes in the
    behavior of Debian's linker.
  * Update debian/copyright.
  * Added include path to VTK5.6.

 -- Michael Hanke <mih@debian.org>  Sun, 13 Mar 2011 20:31:16 -0400

odin (1.8.1-3) unstable; urgency=low

  * Adjust NIfTI build-dependency to libnifti-dev.
  * Bumped Standards-version, no changes necessary.

 -- Michael Hanke <michael.hanke@gmail.com>  Wed, 21 Jul 2010 19:35:42 -0400

odin (1.8.1-2) unstable; urgency=low

  * Switch maintainer to NeuroDebian team.
  * Bumped Standards-version to 3.8.4 -- no changes necessary.
  * No longer depend on atlas, but use libblas-dev.
  * Switch from CDBS to debhelper's dh.
  * Convert the dpkg source package format 3.0 (quilt). Also split Debian
    diff into patch series.

 -- Michael Hanke <michael.hanke@gmail.com>  Sat, 22 May 2010 17:57:51 +0200

odin (1.8.1-1) unstable; urgency=low

  * New upstream release (skipped 1.8.0).
    - Fixes FTBFS (Closes: #562392).
  * Added missing include directive (Closes: #553708). Thanks to Martin
    Michlmayr.

 -- Michael Hanke <michael.hanke@gmail.com>  Sun, 10 Jan 2010 14:24:41 -0500

odin (1.8.0-1) unstable; urgency=low

  * Initial release (Closes: #410318).

 -- Michael Hanke <michael.hanke@gmail.com>  Wed, 30 Sep 2009 21:16:51 -0400