File: bootstrap

package info (click to toggle)
ois 0.99+1.0rc1-2.1
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 976 kB
  • ctags: 1,022
  • sloc: cpp: 5,510; makefile: 101; ansic: 72; sh: 9
file content (27 lines) | stat: -rwxr-xr-x 630 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#! /bin/sh

set -e
# Check for proper versions of autotools
# We require:
#  - autoconf 2.50+
#  - automake 1.6+
#  - libtool 1.4+

# Deal with some gentoo-specific issues
#export WANT_AUTOMAKE='1.7'
#export WANT_AUTOCONF_2_5=1


# clean up files which cause confusion when switch versions of auto*
rm -rf autom4te.cache \
 config.guess config.cache config.sub config.log config.status \
 missing compile ltmain.sh install-sh depcomp

# Fire up autotools
libtoolize --force 
aclocal $ACLOCAL_FLAGS
autoheader
automake --include-deps --add-missing --foreign
autoconf 

#eof "$Id: ois-0.99+1.0rc1/bootstrap -- rzr[a]users.sf.net $"