File: changelog

package info (click to toggle)
olm 3.2.6~dfsg-2
  • links: PTS, VCS
  • area: main
  • in suites: bookworm
  • size: 2,784 kB
  • sloc: ansic: 10,862; cpp: 9,739; java: 3,138; objc: 2,224; python: 1,841; javascript: 1,837; makefile: 456; sh: 218; asm: 7; xml: 1
file content (231 lines) | stat: -rw-r--r-- 7,609 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
olm (3.2.6~dfsg-2) unstable; urgency=medium

  * update symbols file:
    many changes, including removal of public symbol olm_pk_cipher
    which is unused in all reverse dependencies in Debian
  * relax to build-depend unversioned on python3-all-dev:
    required version satisfied in all supported Debian releases

 -- Jonas Smedegaard <dr@jones.dk>  Tue, 21 Sep 2021 13:31:17 +0200

olm (3.2.6~dfsg-1) experimental; urgency=medium

  [ upstream ]
  * new release(s)

  [ Jonas Smedegaard ]
  * update copyright info:
    + use Reference field (not License-Reference);
      tighten lintian overrides
    + update coverage
    + list GitHub issue tracker as preferred upstream contact
    + update source URI
  * use semantic newlines in long description and copyright fields
  * update Homepage URI
  * drop patch cherry-picked upstream now applied
  * unfuzz patch 2001
  * add debian/patches/README documenting patch-naming micro-policy
  * relax symbols check when targeting experimental

 -- Jonas Smedegaard <dr@jones.dk>  Sun, 19 Sep 2021 12:03:06 +0200

olm (3.2.4~dfsg-1) unstable; urgency=medium

  [ upstream ]
  * new release

  [ Jonas Smedegaard ]
  * declare compliance with Debian Policy 4.6.0
  * track library symbols; build-depend on pkg-kde-tools
  * stop pass -sASSERTIONS=1 to emscripten:
    uncertain why it was added,
    and apparently cause build failure with emscripten 2.0.26

 -- Jonas Smedegaard <dr@jones.dk>  Mon, 23 Aug 2021 13:51:37 +0200

olm (3.2.3~dfsg-3) unstable; urgency=medium

  * fix URLs in DEP-3 headers of upstream cherry-picked patch
  * fix post-build cleanup

 -- Jonas Smedegaard <dr@jones.dk>  Mon, 16 Aug 2021 17:16:05 +0200

olm (3.2.3~dfsg-2) experimental; urgency=medium

  * add patch cherry-picked upstream
    to only export olm functions to avoid colliding with other libraries;
    closes: bug#990006, thanks to Evangelos Ribeiro Tzaras

 -- Jonas Smedegaard <dr@jones.dk>  Thu, 17 Jun 2021 18:00:11 +0200

olm (3.2.3~dfsg-1) experimental; urgency=high

  [ upstream ]
  * new release(s), including security-related bugfixes

  [ Jonas Smedegaard ]
  * update source helper script copyright-check:
    skip binary file docs/double_ratchet.dia
    (unlikely to contain copyright info)
  * drop patches cherry-picked upstream now applied
  * install pkg-config file;
    have libolm-dev depend on pkg-config
  * update Node.js install path,
    and have libjs-olm provide node-matrix-org-olm (not node-olm)
  * drop symlink hack in build rules:
    underlying upstream issue seemingly fixed now
  * update patch 1001
  * drop obsolete TODO item about building javascript wrapper
  * update LD_LIBRARY_PATH during build-time test
  * set urgency=high to prioritize upstream security-related bug fixes

 -- Jonas Smedegaard <dr@jones.dk>  Mon, 24 May 2021 18:40:06 +0200

olm (3.2.1~dfsg-7) unstable; urgency=medium

  * fix typo in changelog
  * add patches cherry-picked upstream:
    + specify PRIVATE_KEY_LENGTH const export in index.d.ts
    + fix length calculation of fallback key json

 -- Jonas Smedegaard <dr@jones.dk>  Sun, 24 Jan 2021 12:05:34 +0100

olm (3.2.1~dfsg-6) unstable; urgency=medium

  * fix unset executable bit on browser-targeted files
  * fix limit architecture-independently build-depending
    on brotli pigz uglifyjs
  * install libjs-olm demo code as example files

 -- Jonas Smedegaard <dr@jones.dk>  Sun, 27 Dec 2020 13:53:57 +0100

olm (3.2.1~dfsg-5) unstable; urgency=medium

  * fix paths in JavaScript maps,
    and install also compressed WASM files

 -- Jonas Smedegaard <dr@jones.dk>  Sat, 26 Dec 2020 01:36:10 +0100

olm (3.2.1~dfsg-4) unstable; urgency=medium

  * install browser-targeted javascript files also compressed;
    build-depend on brotli pigz uglifyjs
  * fix modernize test skipping syntax;
    closes: bug#977072, thanks to Christian Kastner
  * update git-buildpage settings:
    + use DEP-14 git branch names
    + add usage comment

 -- Jonas Smedegaard <dr@jones.dk>  Fri, 25 Dec 2020 23:01:13 +0100

olm (3.2.1~dfsg-3) unstable; urgency=medium

  * declare compliance with Debian Policy 4.5.1
  * limit build-dependency on emscripten
    to architecture-independent builds
  * fix set custom HOME during build for emscripten,
    and run a dummy emcc command
    to trigger creating emscripten settings file
  * fix avoid dh_auto_install for architecture-independent builds
  * support parallel build for emscripten build;
    build-depend on recent dpkg

 -- Jonas Smedegaard <dr@jones.dk>  Fri, 20 Nov 2020 22:28:00 +0100

olm (3.2.1~dfsg-2) experimental; urgency=medium

  * add patch 1002 to avoid closure-compiler
    (too ancient release packaged in Debian)
  * support DEB_BUILD_OPTIONS=noopt
  * add new binary package libjs-olm;
    build-depend on emscripten

 -- Jonas Smedegaard <dr@jones.dk>  Tue, 27 Oct 2020 21:41:46 +0100

olm (3.2.1~dfsg-1) unstable; urgency=medium

  [ upstream ]
  * new release(s)

  [ Jonas Smedegaard ]
  * add patch 1001 to use python3

 -- Jonas Smedegaard <dr@jones.dk>  Wed, 07 Oct 2020 01:28:48 +0200

olm (3.1.5~dfsg-1) unstable; urgency=medium

  [ upstream ]
  * new release

  [ Jonas Smedegaard ]
  * fix use debhelper compatibility level 13 (not 12)
  * simplify source script copyright-check
  * check tests verbosely, unless DEB_BUILD_OPTIONS=terse
  * fix cleanup after python build
  * use pybuild
  * declare buildsystem explicitly (not in environment)
  * check python testsuite during build;
    build-depend on python3-future python3-pytest
  * use dh_link to install symlink
  * copyright: update coverage

 -- Jonas Smedegaard <dr@jones.dk>  Sat, 29 Aug 2020 16:59:27 +0200

olm (3.1.4~dfsg-1) unstable; urgency=medium

  [ upstream ]
  * new release

  [ Jonas Smedegaard ]
  * add git-buildpackage configuration:
    + use pristine-tar
    + sign tags
    + ignore any .git files
  * copyright:
    + document files stripped from repackaged source
    + merge identically licensed Files sections
    + separate upstream verbatim License-Grant
      from authored License-Reference
    + list licenses as sections below Files sections
    + fix cover files licensed Expat or ISC
    + extend coverage
    + add myself as copyright holder
    + relicense packaging as GPL-3+
  * drop file README.source (obsolete)
  * add lintian overrides for use of License-Grant and License-Reference
  * watch:
    + use dversionmangle=auto
    + use repacksuffix=~dfsg (to support upstream cleaned rerelease)
    + drop filenamemangle (unneeded)
    + simplify download URL and regular expression
    + add usage comment
  * add helper script copyright-check to source
  * fix support DEB_BUILD_OPTIONS=nocheck
  * update control fields Maintainer Uploader Vcs-*:
    packaging moved to the Matrix Packaging Team
  * use debhelper compatibility level 12 (not 10);
    build-depend on debhelper-compat dh-sequence-python3
    (not debhelper dh-python)

 -- Jonas Smedegaard <dr@jones.dk>  Wed, 08 Apr 2020 18:13:41 +0200

olm (3.1.3+dfsg-2) unstable; urgency=medium

  * Drop Python2 package python-olm. (Closes: #937188)

 -- Hubert Chathi <uhoreg@debian.org>  Sat, 31 Aug 2019 13:29:22 -0700

olm (3.1.3+dfsg-1) unstable; urgency=medium

  * New upstream release.
    * New soname.  However, the C ABI is still compatible, so also provide the
      old soname.
    * New python 3 package.

 -- Hubert Chathi <uhoreg@debian.org>  Tue, 25 Jun 2019 11:56:55 -0400

olm (2.2.2+git20170526.0fd768e+dfsg-1) unstable; urgency=medium

  * Initial release (Closes: #847566)

 -- Hubert Chathi <uhoreg@debian.org>  Mon, 12 Jun 2017 19:18:08 -0400