1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
|
Description: Use system gtest if found
Origin: https://github.com/Ondsel-Development/OndselSolver/pull/82
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 7ca7034..c74e679 100644
@@ -1,11 +1,14 @@
-include(FetchContent)
-FetchContent_Declare(
- googletest
- URL https://github.com/google/googletest/archive/03597a01ee50ed33e9dfd640b249b4be3799d395.zip
-)
-# For Windows: Prevent overriding the parent project's compiler/linker settings
-set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
-FetchContent_MakeAvailable(googletest)
+find_package(GTest QUIET)
+if(NOT GTest_FOUND)
+ include(FetchContent)
+ FetchContent_Declare(
+ googletest
+ URL https://github.com/google/googletest/archive/03597a01ee50ed33e9dfd640b249b4be3799d395.zip
+ )
+ # For Windows: Prevent overriding the parent project's compiler/linker settings
+ set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
+ FetchContent_MakeAvailable(googletest)
+endif()
if(MSVC)
add_compile_options(/wd4251)
@@ -54,7 +57,7 @@ target_sources(test_run
${CMAKE_CURRENT_SOURCE_DIR}/test.cpp
)
target_link_libraries(test_run
- gtest_main
+ GTest::gtest_main
gmock_main
${Google_Tests_LIBS}
OndselSolver
|