File: REQUIREMENTS

package info (click to toggle)
ooolib-perl 0.1.9-1.1
  • links: PTS
  • area: main
  • in suites: buster, stretch
  • size: 256 kB
  • ctags: 59
  • sloc: perl: 1,657; makefile: 90; sh: 78
file content (23 lines) | stat: -rw-r--r-- 970 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
The OpenOffice.org Utility Library has a small set of requirements.  Each
requirement needs to be installed correctly for ooolib to work.

zip requirement:

You are either required to install the zip command or the Archive::Zip Perl
module.  The default is to install the Archive::Zip Perl module as of ooolib
version 0.1.7.  See http://search.cpan.org/~nedkonz/Archive-Zip-1.14/ for
more information abot Archive::Zip.

Zip Command
If you choose the zip command option, first make sure that you have the zip 
command installed.  See http://www.info-zip.org/pub/infozip/ for more
information.  Then, when you create documents, add the "zip" option like these:

$doc = new ooolib("sxc", "zip");
$doc = new ooolib("sxw", "zip");

Archive::Zip
If you decide to use the default method, you will need to make sure
Archive::Zip is installed.  You can either use the CPAN shell, download and
manually install, or for Gentoo users like me, use the command
"emerge Archive-Zip".