1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh $@
override_dh_auto_configure:
@
@
@
dh_auto_configure -- --enable-shared --enable-static \
--with-security --without-slp --with-rundir=/run
override_dh_auto_build:
dh_auto_build
dh_auto_build -- \
SOLIB=libisns.so.0 \
SOLIB_SONAME=libisns.so.0 \
LIB=libisns.a \
libisns.a libisns.so.0
override_dh_auto_install:
@
@
@
dh_auto_install -- install_hdrs install_lib
@
make -j1 DESTDIR=$$PWD/debian/tmp \
SOLIB=libisns.so.0 \
SOLIB_SONAME=libisns.so.0 \
LIB=libisns.a \
install_lib
override_dh_installinit:
dh_installinit -popen-isns-server --name=isnsd
dh_installinit -popen-isns-discoveryd --name=isnsdd --no-start
dh_installinit --remaining-packages
override_dh_makeshlibs:
dh_makeshlibs -plibisns0t64 --add-udeb="libisns-udeb"
dh_makeshlibs --remaining-packages
|